0

I am trying to read passive tags using these two devices and an arduino uno, for a class project of trying to make my own doggy door. However, all the code I have been able to find is out of date, including the code on the sparkfun product site ( I think the code is out of date not 100% sure?). I think the main issue with the code is that is based on SoftwareSerial instead of NewSoftSerial. So if anyone has any experience programming with RFIDs (hopefully this device in particular) I would love any pointers, example code, help, words of advice, etc., The code I tried to use is available on the links. Also, I am by no means an expert in any of these fields, so if anything I said is wrong please correct me. P.S., I do not believe it is a wiring issue since these are both shields, and I did very clean soldering. The "Power" LED on the evaluation sheet/antenna is on, but the "Search" and "Found" LED's never light up (even with a tag making contact with the board). Reference of Devices: https://www.sparkfun.com/products/10126 - RFID Module SM130 https://www.sparkfun.com/products/10406 - RFID Evaluation Shield

  • 1
    What exactly is the problem? Also provide your code and schematic. – TisteAndii Apr 8 '16 at 21:37
  • my code is literally just the offered sample code on sparkfun.com/products/10406 and I'm combining the two modules as can be seen in their example video on sparkfun.com/products/10126 . From top bottom it goes green (SM 130), red (the 13.56 mHZ shield), then blue (Arduino Uno) . The problem is that I cannot get the RFID reader to detect RFID tags, and I do not even think it is searching. So the "Found" and "Search" light indicators on the Shield are not lighting up. – Sam Greenberg Apr 11 '16 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.