0

I'm working on a project that has something to do with receiving gps data from the satellites. With this, I've used GPS NEO 6M with an arduino Lilypad for wearable purposes.

I've already tried using the Arduino Mega ADK and it's working with my codes before I used Lilypad.

With pin connections:

Lilypad GPS Vcc ----------> Vcc GND ----------> GND D4 ----------> TX D3 ----------> RX

And here is the code I used for it:

  #include "TinyGPS++.h"
  #include "SoftwareSerial.h"

  SoftwareSerial serial_connection(4, 3); 
  TinyGPSPlus gps;//This is the GPS object that will pretty much do all the grunt work with the NMEA data
  void setup()
  {
  Serial.begin(9600);//This opens up communications to the Serial monitor in the Arduino IDE
  serial_connection.begin(9600);//This opens up communications to the GPS
  Serial.println("GPS Start");//Just show to the monitor that the sketch has started
  }

  void loop()
  {
  while(serial_connection.available())//While there are characters to come from the GPS
  {
  gps.encode(serial_connection.read());//This feeds the serial NMEA data into the library one char at a time
  }
  if(gps.location.isUpdated())//This will pretty much be fired all the time anyway but will at least reduce it to only after a package of NMEA data comes in
  {
//Get the latest info from the gps object which it derived from the data sent by the GPS unit
  Serial.println("Satellite Count:");
  Serial.println(gps.satellites.value());
  Serial.println("Latitude:");
  Serial.println(gps.location.lat(), 6);
  Serial.println("Longitude:");
  Serial.println(gps.location.lng(), 6);
  Serial.println("Speed MPH:");
  Serial.println(gps.speed.mph());
  Serial.println("Altitude Feet:");
  Serial.println(gps.altitude.feet());
  Serial.println("");
  }
  }

 /*
* $GPRMC,183729,A,3907.356,N,12102.482,W,000.0,360.0,080301,015.5,E*6F
$GPRMB,A,,,,,,,,,,,,V*71
$GPGGA,183730,3907.356,N,12102.482,W,1,05,1.6,646.4,M,-24.1,M,,*75
$GPGSA,A,3,02,,,07,,09,24,26,,,,,1.6,1.6,1.0*3D
$GPGSV,2,1,08,02,43,088,38,04,42,145,00,05,11,291,00,07,60,043,35*71
$GPGSV,2,2,08,08,02,145,00,09,46,303,47,24,16,178,32,26,18,231,43*77
$PGRME,22.0,M,52.9,M,51.0,M*14
$GPGLL,3907.360,N,12102.481,W,183730,A*33
$PGRMZ,2062,f,3*2D
$PGRMM,WGS 84*06
$GPBOD,,T,,M,,*47
$GPRTE,1,1,c,0*07
$GPRMC,183731,A,3907.482,N,12102.436,W,000.0,360.0,080301,015.5,E*67
$GPRMB,A,,,,,,,,,,,,V*71
*/

This code was working when I used the mega ADK. And I concluded now that the program is not the issue why it's not working and receiving any gps data from the satellites above. Does anybody here have tried working similarly with this project using Lilypad arduino? I kept banging my head figuring out the possible reason why my GPS is not working with the Lilypad.

I hope you can help me with this.

Cheers!

  • what does "not working" mean? please supply error codes. – tony gil May 31 at 19:55
0

Working code and schematics for Neo 6 and Lilypad.

Try this and, if you still have "not working" situation, please inform problem in more detail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.