0

I recently bought a brand new Arduino pro micro from Amazon, I set it up according to the instructions on sparkfun, except that when I plug it in, Windows doesn't even show that it tried to install device driver software. I figured it might just be a windows 10 thing because the tutorial was written on windows 7, so I forged ahead, and updated the device driver for COM3 in device manager, and attempted to upload a simple test for HID emulation:

#include <Keyboard.h>

void setup() {
  Keyboard.write('z');
}

void loop() {
  Keyboard.write('a');
  delay(5000);
}

It compiled just fine, and the IDE said it started uploading to the device, However, as it was uploading (or so I thought) I read a little farther and realized that the IDE wasn't set to use the right voltage (3.3V instead of 5V) I closed the IDE and reopened my sketch, changed the voltage to match up, and tried uploading it again. Here, it got stuck on the Uploading... text and so again, I closed the IDE.

Only the LED closest to the USB port is on, and it's solid green. I've connected to my computer using a Micro USB to USB adapter, and I initially plugged the board into a USB 3.0, but then switched to 2.0 to see if it made a difference. I have also tried it on Ubuntu 14.04 with no luck. I don't think it's bricked because if it was, my computer would still recognize it, but not know what it was (according to sparkfun), and as a result, I have yet to try the debricking method they suggest. Any thoughts?

  • Just to check, which method did you use to reset the pro micro mentioned by sparkfun, did tou use the double tap of the RST pin? – RSM Mar 31 '16 at 8:46
  • @RSM yes, I connected a jumper cable to the gnd pin and tapped the reset pin twice with the other end of the wire. – J. Doe Mar 31 '16 at 12:01
  • Ok, do you have another arduino board you can use as an ISP programmer – RSM Mar 31 '16 at 12:05
  • @RSM no, but I can easily get one – J. Doe Mar 31 '16 at 12:24
  • or you can get an ISP programmer. Also the LED by the USB is power it will always be on. Does the PC make a sound when you reset the board. And adding to this the board does not have the Pro Micro bootloader but the leonardo, try switching to that board in the IDE and let me know what happens – RSM Mar 31 '16 at 12:33
1

The Pro Micro, like the Leonardo, cannot automatically reboot into the bootloader like boards such as the Uno and Mega. Instead it relies on the sketch running on it listening for a special combination of events (open the serial port, set the baud rate to 1200 baud, close the serial port) to activate the bootloader.

If, for whatever reason, you don't have a working sketch installed on the board (such as you aborted the upload part way through) then there will be nothing there to listen for the "reboot into bootloader" instructions.

So you need to manually enter the bootloader. Fortunately it should be easy enough, but timing is all important.

When you first plug the board in, or when you press the reset button, you get a few seconds where the board is in the bootloader. On the Leonardo that is signified by the LED glowing and pulsating - I don't know off hand what is shown on the Pro Micro.

As long as you press the reset button just before you compile and upload your sketch, and as long as the upload portion doesn't take too long to start (tip: compile it before uploading, it makes it faster) it should then install the sketch into the board and from then on the auto-reboot should start working.

(Note: I haven't used a Pro Micro - this is all from my experience with the Leonardo which I believe uses the same bootloader.)

  • Still no luck, I followed the instructions that sparkfun gave for resetting, using a piece of wire I had, and there was no change in the LED. I did accidently touch the other end of the wire to the "RAW" connector, and the LED turned off, but otherwise there was no change, I'm still stuck on Uploading... – J. Doe Mar 31 '16 at 3:56
1

You have to retrieve the VID/PID numbers your board actually has and change your boards.txt accordingly. On my Linux computer I made a USB connection with my corrupted pro micro clone, "lsusb" does not show it, but if I pull rst-pin down (pulse) "lsusb" does show it for a few seconds. Now I know the vid:pid numbers. I edited boards.txt (~/.arduino15/packages/Sparkfun/hardware/avr/1/1/5/:

promicro.build.vid=0x1b4f (edited 1b4f with vid outcome of "lsusb")

promicro.menu.cpu.16MHzatmega32U4.build.pid.0=0x9205 (9205 edited)

Then in Arduino IDE I gave a reset pulse, the port showed up. I loaded the sample blinky script from sparkfun (https://learn.sparkfun.com/tutorials/pro-micro--fio-v3-hookup-guide#faq-change-pid), clicked "upload" and once again gave a reset pulse. The upload succeeded and my pro micro clone is back to normal.

  • That "reset > upload > reset > done" procedure actually resurrected my stuck Micro Pro. Upvote :) – Fusseldieb Jan 9 '18 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.