Last week I purchased a couple of Trinkets from Adafruit (5v micro-USB). The first thing I did was solder the headers to one of them. I did the whole setup process w/ the Arduino IDE and didn't have any issues, until I actually tried uploading the "Blink" example.

When I plug in the Trinket, I get the pulsing red light, but when I try to upload during that, I get:

avrdude: error: usbtiny_send: Input/output error (expected 64, got -5)
avrdude: verification error, first mismatch at byte 0x0004
         0x1d != 0x36
avrdude: verification error; content mismatch

avrdude: error: usbtiny_transmit: Input/output error

Then, if I press the reset button, I can't get it to "pulse" again. The red light just dimly turns on and stays constant.

I tested the other Trinket I ordered (that has not been soldered yet) and it works perfectly fine.

So, did I somehow screw up something when soldering the headers? Or do I have a faulty Trinket?

For reference, here's the trinket in question...

enter image description here

  • 1
    Is that yours? Or a stock photo from Adafruit? The soldering looks very neat.
    – Nick Gammon
    Mar 28, 2016 at 2:30
  • This may help: <learn.adafruit.com/introducing-trinket/repairing-bootloader>
    – Nick Gammon
    Mar 28, 2016 at 2:34
  • @NickGammon Yes, it's mine. Was my first thing to solder...ever. So wasn't sure if I somehow botched it and just didn't know. Will give the bootloader repair a try.
    – Shpigford
    Mar 28, 2016 at 3:04
  • What kind of soldering iron do you have? How hot did you solder it and was it properly grounded?
    – aaa
    Apr 28, 2016 at 10:11

2 Answers 2


There are what appear to be burn or melt marks on the 5 pin component labeled QTSO and on the diode near the USB pin. That could be a sign of damage due to soldering, reverse polarity, or excessive current draw through the voltage regulator (a short circuit).

Based on the fact that the light stays on solid when the reset button is pressed, it sounds like it could also a different issue. First, turn on verbose output in the arduino IDE and post the full output when you try to upload.

Next, try disconnecting everything except the USB cable while uploading the program. If that does not fix it, it is most likely that the bootloader is corrupted. This has happened to me on multiple occasions for no apparent reason and it is pretty easy to fix.

If repairing the bootloader does not fix this, it is most likely that one or both of the components mentioned above are damaged.

  • The 5 pin component is the 5V regulator that provides power to the microcontroller if you're using a battery. The diode is there to just to make sure that the Vout of the 5V regulator isn't visible on pin 1 of the USB. I can say with almost 100% certainty that the components are fine. The fact that the LED is on but is dim makes me believe that the PB1 pin of the ATTINY is floating which suggests it's either ESD damage to the chip or some sort of corruption to the bootloader
    – Mukira
    Apr 29, 2016 at 9:26

On this side it doesn't seem like there's a solder bridge, although it's possible there is one on the other side if you were heavy handed on the solder.

Since you did the verification with the other unit this can't be a software or usb cable issue.

So indeed it's coming from the trinket itself. I think your best bet is to desolder the pins and check the upload again. If it's failling, try flashing a new bootloader. And if it's still not working then I guess either it was faulty from the start or you did damaged a component during the soldering.

  • 2
    Trying to desolder the pins is only likely to make things worse. In theory it can be done, probably by heating them one by one with an iron and pulling each out of the board and plastic keeper individually with pliers, but it's unlikely to improve the state of the board. Carefully sliding the plastic keeper down so the bottom of the pins could be examined makes as much sense - a little hot air (but short of soldering temperature) can help with that. Checking for shorts electrically is probably the most sensible. Apr 27, 2016 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.