0

When I plug the USB cable to my Arduino and try to upload a sketch I get thtis error:

avrdude: ser_open(): can't open device "/dev/cu.usbmodem1411": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device

when I go to Tools > ports I can't find the USB port. The Arduino still working and green ligh is on, so what is the problem exactly?

4
  • Does the Uno show up under  -> "About this Mac" -> "More info" -> "System Report"->"Hardware"->"USB"? – Gerben Mar 21 '16 at 14:20
  • You should really search on Arduino Inappropriate ioctl possibly with mac that would give you some results worth reading. arduino.stackexchange.com/questions/13299/… or forum.arduino.cc/index.php?topic=292284.0 and askubuntu.com/questions/646254/arduino-serial-port-com1-problem are all people with the same error message. Try what worked for them. – Paul Mar 21 '16 at 14:22
  • Probably never mind, since the Arduino isn't even recognized by the PC, try to fix that first. If you try another Arduino, you would be able to tell if the problem is on the PC or on the Arduino. – Paul Mar 21 '16 at 14:28
  • Actually, you might still want to check out those links. Try running your IDE as administrator (or what it is at mac). – Paul Mar 21 '16 at 19:06
2

Have heard of similar problems with Mac. Not a Mac user myself. Sometimes the Arduino can somehow trigger a current fault in the USB of Mac's and will need to be shut down and rebooted for it to work again.

Try rebooting your Mac.

If you have a cheap chinese Arduino you might need other drivers for it. Check what chip you have closest to the usb connector.

7
  • I have tried with 2 Mac laptops, same thing happened. an electronics guy told me that the IC is burnt, is this right? – Afnan Humdan Mar 21 '16 at 13:07
  • I would check that you have the correct driver before i would make that assumtion. – Hans Neve Mar 21 '16 at 13:08
  • @AfnanHumdan and I would check it again, because the "the IC is burnt" is the common way to say "I don't have the time to look at it, so just change it". Moreover you didn't say if the board ever worked. Then try using another pc (not a mac) just to double check. If it doesn't work, maybe flashing again the firmware on the atmega16u2 (the usb-serial interface IC) can solve the problem.. – frarugi87 Mar 21 '16 at 13:21
  • The Arduino only requests 100mA from the USB port. If you draw more than that it may decide to cut you off. 100mA is somewhat conservative (they could have set it to ask for 500mA) but it does allow it to work on an unpowered hub without the hub shutting it off - as long as you stay within that 100mA budget. Many systems ignore that limit though and provide many amps of power, but the Mac may be more sensitive. – Majenko Mar 21 '16 at 13:33
  • @Majenko the Arduino request 100mah and could ask for 500 mah. I beg you to explain this. The usb 2.0 standard says a port should be able to deliver 500mah, whether the arduino draws that from the port or not is irrelevant unless exceeding 500mah where the controller might disconnect your device. – Hans Neve Mar 21 '16 at 15:58
-1

I was also facing this type of issue. But it has resolved itself now. I go to Tool >> Select Port after Select USB modem its work fine.

7
  • 1
    This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Juraj Mar 17 '18 at 11:36
  • I can't agree this isn't an answer. It clearly spells out what to do to resolve the issue. If that doesn't solve the problem that is another issue. To whoever has been flagging this, answers are not to be flagged merely because they are wrong. – Nick Gammon Mar 17 '18 at 21:46
  • @NickGammon, the question is a Mac specific problem, where no ports are listed in IDE. how does this 'late' and 'me-to' answer answer the question? ('my' previous comment was generated by SE) – Juraj Mar 19 '18 at 11:16
  • @Juraj On the Mac you get Tools -> Ports, as mentioned in the question. Bad answers don't have to be flagged for moderator attention. Just leave a comment stating why it won't work in your opinion and optionally vote it down. – Nick Gammon Mar 19 '18 at 20:57
  • @NickGammon, SE system asked me if this is a low quality late answer that should be deleted. I didn't flag it directly – Juraj Mar 20 '18 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.