0

I have found a similar qustion to mine but there was no good response.

I've connected my ESP8266 to Arduino UNO.

Then I got some trouble with software serial communication with Arduino and decided to change baud-rate to 9600 (previously it was 115200).

I used AT+IPR=9600 command to change it.

After that blue led of esp stays on and not taking AT commands any more, but output some gibberish to serial monitor.

Note: I connected the esp8266 through a voltage regulator and a power source and both gave the same problem. My firmware is supposed to be updated so I don't think that it is the issue.

Could anyone please help me?

  • You have changed the baudrate. Try to match up your UNO's baudrate with your new baudrate. Unmatching baudrates will indeed cause gibberish. Maybe the "updated firmware" is actually the problem, since the device isn't responding well, try to re-update the firmware (when you know which baudrate it is). – Paul Mar 17 '16 at 10:07
0

Did you change the firmware? I think Baud rate can be changed only if you flash it with newer version of the firmware.

  • Yes I changed the firmware. The problem is that when trying to change the baud rate back it is not accepting any AT commands even though I tried with different baud rates. – William Vella Mar 16 '16 at 15:08
  • as mentioned by paul, have you tried to reupload the firmware ? I found Nodemcu Flasher to be the easiest way to upload the firmware. Also create your self a simple flashing setup like this one. It is worth making if you plan to use ESP8266. – NccWarp9 Mar 18 '16 at 9:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.