2

i am using ESP8266 module serially with PC and i also tried it using uno I am stuck at the following point I am able to made connection to server but when i will send the following command

POST /test.php HTTP/1.1\r\nHost: 192.168.1.36\r\nContent-Type: application/x-www-form-urlencoded\r\nContent-Length: 5\r\n\r\nb1=ON\r\n\r\n

every time i get the following server timeout error after 3 sec

+IPD,4,500:HTTP/1.1 408 Request Timeout Date: Tue, 08 Mar 2016 14:10:07 GMT Server: Apache/2.4.9 (Win64) PHP/5.5.12 Content-Length: 305 Connection: close Content-Type: text/html; charset=iso-8859-1

408 Request Timeout

Request Timeout

Server timeout waiting for the HTTP request from the client.


Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

4,CLOSED

And i am getting same issue whether i will use local server or online server

5
  • If you post the same string to your server(s) from your PC, bypassing the ESP8266, do you get the same error?
    – Dave X
    Mar 8 '16 at 14:49
  • no through PC i m getting the repsonse from server Mar 8 '16 at 15:13
  • Try adding Connection: close\r\n to the header. Also remove the \r\n\r\n at the end. Lastly, are you using the correct length in AT+CIPSEND=...?
    – Gerben
    Mar 8 '16 at 15:13
  • Try turning off your firewall.
    – Majenko
    Mar 8 '16 at 15:13
  • 1
    yes i am sending the correct length Mar 8 '16 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.