0

What I've tried:

  • I downloaded the package for 1.6.7 on Ubuntu 14.04 LTS but when I open it no matter what I try it will not start.
  • I installed 1.0.5 from the Ubuntu Software Center. I tried to update it but found no solution.

UPDATE: I found my answer in talamaki's answer on that other question linked above.

3
  • You say that you downloaded it, have you actually installed it? What command did you use? Where was it installed to (updatedb;locate arduino)? What happens it you try to run it from the command line? Is it in your path (echo $PATH)? You may need to update, or manually fix, the desktop shortcut, which is currently pointing to 1.0.5. Please edit, and expand upon, your original post with more details. Mar 3 '16 at 5:01
  • @LinuxAut2115 did you run the install script inside the tar file? Usually it replaces any arduino.desktop launcher present
    – brtiberio
    Mar 3 '16 at 16:14
  • If you download 1.6.7 from the Arduino Downloads page, un-archive it, and then double-click the "Arduino" file inside the download, you will get 1.6.7. That's exactly how I use it. I'm going to close this as a duplicate of a similar question. The answer there has more details.
    – Nick Gammon
    Mar 3 '16 at 20:53
0

Follow the following step to download, install and run Arduino IDE on Ubuntu

  1. First Download the Tar (tar-bal) from this link http://arduino.cc/en/Main/Software (download the correct 32 / 64 bit linux version ) depends upon your Ubuntu version.
  2. Then goto download folder using terminal (shell) or the folder where you downloaded the tar and unpacked that tar using the following commands like cd /Downloads tar -zxvf arduino-1.6.7-linux32.tgz where 1.6.7 is the version of ide

  3. you also need java runtime environment for arduino IDE download and install it using the following command sudo apt-get install openjdk-7-jre

  4. you also need to provide the UART permissions for your hardware using following commands sudo chmod a+rw /dev/ttyACM0 where ACM0 is the port number if you are using multiple or many arduinos just give permissions using the above commands by replacing the ACM0 to ACM1 to ACMN

    1. then create a shortcut of arduino ide from the folder where you extract the tar cd ~/Desktop ln -s /Downloads/arduino-1.6.7/arduino

and then double click the shortcut to run arduino if it gives permission error then right click the shortcut and in file preferences gives permissions to the shortcut

Not the answer you're looking for? Browse other questions tagged or ask your own question.