5

I just installed the 1.6.7 version and want to upload it a sketch to Arduino UNO hardware. I get error message:

/home/pali/Irataim/TarBalls/Arduino/arduino-1.6.7/hardware/tools/avr/bin/avrdude: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

I'm on Gentoo linux operating system.

How can I solve this problem?

By following this link:

https://forums.gentoo.org/viewtopic-p-7815500.html?sid=f67283068e3655b2f9e259a2097efef6
I just add tinfo USE flag to ncurses package, re-emerged it and can run Arduino IDE that I emerged from Gentoo repository.

  • (Install dependencies with emerge -avq sun-jre-bin crossdev) Run equery belongs libtinfo.so , if the library exists then try symlinking the libraries: ln -s /lib64/libncurses.so.5 /usr/lib/libtinfo.so.5 and ln -s /usr/lib/libtinfo.so.5 /usr/lib/libtinfo.so. – Avamander Mar 3 '16 at 21:09
  • I did so, but there is no libtinfo.so library. – user18811 Mar 5 '16 at 9:22
  • equery belongs libtinfo.so there is none? – Avamander Mar 5 '16 at 21:39
  • Exactly! There is none libtinfo.so out there. – user18811 Mar 7 '16 at 6:29
  • 1
    @PalCsanyi in the stack exchange system, questions are marked resolved not by editing the title, but by accepting an answer. If none of the provided answers matches your solution, provide your own and accept that, however it does look like at least one of them matches what you said you did. – Chris Stratton Oct 15 '16 at 15:50
3

Install libtinfo5, the terminfo library.

If that doesn't help, you can try to debug the problem yourself. First, check which libtinfo avrdude is looking for:

ldd arduino-1.7.8-linux64/hardware/tools/avr/bin/avrdude_bin | grep libtinfo

On my Ubuntu, I get this:

libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007fa74a888000)

Next, see where your libtinfo is installed:

find /lib /usr/lib -name 'libtinfo*'

On my system I get:

/lib/x86_64-linux-gnu/libtinfo.so.5
/lib/x86_64-linux-gnu/libtinfo.so.5.9

Do you have any discrepancy between the two?

| improve this answer | |
  • I just installed terminfo package, the Haskell bindings to the terminfo library and try to upload again a sketch. I get the same error message: arduino-1.7.8-linux64/hardware/tools/avr/bin/avrdude: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory. However, I'm using now the just downloaded arduino-1.7.8-linux64 package. – user18811 Mar 2 '16 at 18:36
  • @PalCsanyi: Then I do not have the solution, but I added some hints to help you debug the problem. – Edgar Bonet Mar 2 '16 at 19:03
  • I tried followings on my Gentoo linux: ldd arduino-1.7.8-linux64/hardware/tools/avr/bin/avrdude not a dynamic executable find /lib /usr/lib -name 'libtinfo*' There is no output. – user18811 Mar 2 '16 at 19:23
  • @PalCsanyi this topic refers to have similar problem and got it solved using a symbolic link to libncurses. Take look: forums.gentoo.org/… – brtiberio Mar 2 '16 at 20:15
  • 1
    @Personagem Indeed, there is a solution for me. Thanks!! forums.gentoo.org/… – user18811 Mar 7 '16 at 16:53
1

You have to rebuild sys-libs/ncurses with tinfo USE flag turned on. (You can also make a symlink: libtinfo.so -> libncurses.so, but it's not elegant solution).

Firstly, check if you have a record for ncurses in any file in /etc/portage/package.use. If not, create a file /etc/portage/package.use/ncurses with such content:

sys-libs/ncurses tinfo

then, rebuild ncurses:

emerge -av sys-libs/ncurses
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.