0

I'm at a loss. I have many boards and have not had much trouble in the past uploading to feather, uno, light blue bean and others. I have a lot of boards loaded in the board manager and I'd rather not delete everything just yet.

But, after taking a month off of arduino programming I've come back to the app to discover that I can't upload anything to any board. I've tried a brand new uno, an adafruit feather and the light blue bean. In each case I can see the port, but the upload just hangs like this:

enter image description here

On the board the light that normally blinks during upload never blinks. It's like the upload just isn't happening. But there is no error in the app.

I tried reinstalling the app, but that didn't help. My next thought is to delete everything, and do a fresh install. Which will be annoying. Is that my only hope?


UPDATE:

Here are the settings from the tools menu as requested:

enter image description here

enter image description here

6
  • In the Tools menu, what do you have set for the Board, Programmer and Port?
    – Gerben
    Feb 27, 2016 at 17:12
  • I added that information.
    – futurebird
    Feb 27, 2016 at 17:21
  • Try changing programmer to AVR ISP.
    – Gerben
    Feb 27, 2016 at 19:38
  • I tried AVR ISP. Same issue. In fact, that is what I normally have it on. I was trying ArduinoISP when I took the photos to see if that would help.
    – futurebird
    Feb 27, 2016 at 19:57
  • Do you have an ISP device or not? If not, there is no point in using Upload Using Programmer. If so, you must use that. after taking a month off of arduino programming - it looks like a Mac. Have you upgraded the Mac operating system in the meantime?
    – Nick Gammon
    Feb 28, 2016 at 1:30

2 Answers 2

1

I tried that once. A very common reason for this problem is a different cable. Some USB cables are not suited for uploading the data to the Uno board.

Have you brought a new cable? If so, switch back to the old one. It may not look like it makes a difference, but it requires attention.

2
  • Thanks for the suggestion. But this was not the issue. I have had the issue with cables before and it would at least cause and error in the app. But, just to check I have tried many combinations of cables old and new and this error persists. I think I will just have to delete everything and see if that works.
    – futurebird
    Feb 27, 2016 at 21:29
  • Also try plugging in several boards at once (on several USB ports), to allow testing different serial ports. Possibly run fuser or similar program on /dev/SLAB_USBtoUART Feb 27, 2016 at 22:17
1

I appreciate that this is an old post but I have recently been experiencing this problem.

I found that the issue was caused when I had a wireless SD shield attached to the Arduino. Taking this shield off allowed me to upload. This occurred across 5 different Arduino's.

After some more testing I found that switching the "serial select" toggle on the wireless shield from "MICRO" to "USB" allowed me to upload as well. Switching it back to "MICRO" subsequently blocked the upload.

Hope this help anyone having this problem in the future.

4
  • 1
    You should ask the original questioner if a SD shield was used, I don't think so since the OP state "brand new uno, an adafruit feather and the light blue bean".
    – MatsK
    Mar 14, 2019 at 19:45
  • I was also using brand new Arduino boards. I doubt the original poster is having this issue still 2 years later. I am merely contributing an answer for future readers as I experienced this issue today and this question is one of the first search results when Googled.
    – loogle1
    Mar 14, 2019 at 20:38
  • Since you are making asumptions, you should use the comment since it's not a answer.
    – MatsK
    Mar 14, 2019 at 20:40
  • Well it is an answer... Other people gave potential solutions too just like this one - making assumptions. Maybe go and answer a question or two rather than nit-picking people providing input on a problem they have come across.
    – loogle1
    Mar 14, 2019 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.