3

I can't appear to get my MKR1000 to list a port on my mac in the arduino ide, am i missing something obvious or does it need additional drivers?

Also ➜ ~ csrutil status System Integrity Protection status: disabled.

running OSX 10.11.3

Board appears to be working, default led flashing

6
  • What does dmesg tell you? – Majenko Feb 15 '16 at 22:13
  • i get a new lines 036284.257826 IOUSBHostDevice@14100000: IOUSBHostDevice::getDescriptorGated: type 0x03 index 2 length 2 completed with 0xe00002e8 and bytesTransferred 0 036284.258099 IOUSBHostDevice@14100000: IOUSBHostDevice::getDescriptorGated: type 0x03 index 1 length 2 completed with 0xe00002e8 and bytesTransferred 0 – JohnC Feb 15 '16 at 22:15
  • Is that what you get when you plug the mkr1000 in, or just while it's idle? – Majenko Feb 15 '16 at 22:16
  • when i plug it in – JohnC Feb 15 '16 at 22:18
  • Have you installed the drivers? (If there are any?) – Avamander Feb 15 '16 at 22:57
2

Double click the reset button on the board. Then it will show in the Port list :-)

2
  • Worked for me, thanks! For others: don’t forget to install the board in Arduino board manager as described here: arduino.cc/en/Guide/MKR1000. – Pwdr Oct 17 '16 at 13:50
  • I also had to use another (shorter) USB cable. – Pwdr Oct 17 '16 at 13:57
-1

See if this answers your question: https://www.hackster.io/charifmahmoudi/arduino-mkr1000-getting-strarted-08bb4a

If not, go to your Board Manager (this happened to me too) and search MKR1000. There should be another install to do. Install that one and you should be good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.