-1

I was trying to switch to Atmel Studio for programming my Due project since it became more and more complex. I managed to use the Arduino Importer Wizard to load a blink.ino file and included all the requested libraries more or less my hand that were marked as missing during compiling. Now the compiling kind of works, but I still get this error:

Error       (inkerScript): No such file or directory    ECU arm-none-eabi-g++.exe   0

The (inkerScript): part is no typo. It is really like this in the console. Taking a look in the Toolchain Options I have these settings (which I am not able to edit): Linker Options

Going into the Miscellaneous Part of the Options I can edit these fields: Miscellaneous Options

By editing the Linker Flags field, I can change the error message from (inkerScript): No such file or directory to e.g. HelloWorld: No such file or directory.

Is there anything wrong with my options? What is the correct setting for "Linker Flags" and what are they doing?

Unfortunately I am not a pro with C++ Compiling / Linker Errors / Settings.

Thanks.

0

I just encountered this. After looking at other examples in the compiler command line options, it looks like it should be $(LinkerScript) instead of ($LinkerScript).

In Atmel Studio, go to project properties, toolchain, ARM/GNU Linker, Miscellaneous to find the option to change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.