1

Last month, I bought an Arduino Uno R3 board (believed to be a clone). In the first few week, it seem to be working fine. However, in this week, it became very strange. What it basically does, it sometimes can be connected and detected by the computer and serial connection can be opened. However, after a specific amount of time, it started to be hidden and cannot be detected by the computer. The device is not even in device manager with [show hidden devices] turned on. It is extremely weird because after a specific amount of time again (~12-24 hours), it started to work normal again and can be detected and programmed by my computer. It is extremely weird and this combination of incidents continues to loop in the past couple days. I really need some personal help since the information and methods in the internet never helps me.

My specs: Windows 7 Professional 64 bit, Arduino IDE and driver 1.6.7

What i had tried:

[WHEN IT CAN BE DETECTED]

  • Nothing. Since it was working fine, I didn't attempt to perform any action because I afraid it will worsen the situation
  • Tried to re-flash the Mega16u2 Chip using the application Flip, but it cannot be turned into DFU mode apparently

[WHEN IT CANNOT BE DETECTED]

  • Unplug and plug it again
  • Tried to use a different cable
  • Tried to use a different PC (Windows 10)
  • Tried to update the driver, however when I check the device manager, it didn't show any COM ports or whatever, also there's no unrecognized device. I have checked 'show hidden devices'.
  • Installed Arduino UNO driver (not able to start, error code 10)
  • Installed FTDI drivers (also not able to start, error code 10)
  • Reinstalled the whole Arduino IDE and drivers

Any answers are appreciated.

closed as off-topic by Chris Stratton, MatsK, user31481, Code Gorilla, gre_gor Jan 16 '18 at 15:01

  • This question does not appear to be about Arduino, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Cheap clone = cheap components = poor tolerances. Maybe something like the USB crystal is drifting outside of the range that is allowable for USB communication? – Majenko Jan 23 '16 at 15:25
  • Does it have an FTDI chip, or an 16u2 for USB connection? Also, does the Arduino continue it's program (blinking LED's for example) when it's not discoverable in the device explorer? – Paul Jan 23 '16 at 15:30
  • Sorry for the late reply, it had a 16u2 chip for USB connection. Also, when the USB is not working, the last uploaded program on it is working fine. It act like a normal Arduino with working program but no USB connection. – doge2048719 Jan 27 '16 at 9:06
  • 3
    I'm voting to close this question as off-topic because information to make it answerable has never been provided. – Chris Stratton Jan 15 '18 at 4:08