-1

I have ESP8266, FTD232 UART, Linux mint 17.3 OS, Arduino IDE 1.6.7,

Following are the connections:

External Power source  ESP8266
  3.3 V                  VCC
  GND                    GND
  3.3 V                  CHPD
  3.3 V                  GPIO0

FTD232 UART  ESP8266
    RX         TX
    TX         RX

Plus FTD232 GND and Power Source GND are connected to make sure that there is a common reference.

I open the Arduino IDE and select Generic ESP 8266 board.

Open Serial Monitor:

AT command, no response..?

I have tried lots of different things found from web, even a new ESP8266, but no response.

Can anybody provide help...?

  • Is your serial monitor set to BOTH NL & CR? – TisteAndii Jan 23 '16 at 9:15
  • Which model ESP8266? – Majenko Jan 23 '16 at 10:43
  • Yeah Both NL & CR And Baud Rate 9600, ESP8266-01 Model, the one with 8 pins and 2 GPIO. – Raj Jan 24 '16 at 12:55
  • Dont select 'Generic ESP8266'; leave the default IDE settings. Simply connect the ESP, open the serial monitor, and try sending commands at 9600 or 115200. Or you can use minicom to send the commands directly without the IDE – TisteAndii Jan 24 '16 at 22:19
0

The ESP8266-01 will boot and show some boot up messages at baud rate 76800 before switching to the default configured baud rate of 9600 or 115200.

Try setting the baud rate to 76800 and reset the ESP8266 to see if you can see the boot up messages first to determine if your circuit is working. You might see something like this:

ets Jan 8 2013,rst cause:4, boot mode:(3,7)

  • Just a note on the "initial" baud rate of these devices ... many ESP8266's use a 26MHz rather than 40MHz crystal - this apparently does not change the clock rate of the MCU, but it does effect the boot loader baud rate ... what should be 115200 becomes 74880 (not a conventional rate, but is supported by arduino ide at least) the reason for this oddball rate ... 115200 * 26 / 40 = 74880 - I guess the boot loader is setting the uart for what it thinks is 115200 before the necessary "adjustments" for 26 vs 40MHz crystal is taken into consideration. – Jaromanda X May 24 '16 at 11:43
0

enter image description here 1.What firmware ? AT commands do not work in nodeMcu firmware. Usually the AT firmware work to 115200 bps.

2.If your FTD232 works at 5V, you will need resistor between Arduino TX and ESP RX. ESP8266 only works at 3.3V.

3.Try esplorer - is a very nice tool to test ESP8266: http://esp8266.ru/esplorer/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.