3

I have an Arduino Nano which is Powered by an external Power supply. This is connected with VIN and GND. The voltmeter says, there are 12,12 V

I have some components connected on the 5V PIN, which altogether draw max. 100mA Since some of the components are not working anymore, I started measuring...

I have disconnected everything, but the Arduino Nano Power supply. (12,12V)

When I now measure GND and the 5V PIN, the Voltmeter says 6,97V! I guess this is why my components are giving up.

  • But why are there 6,97 Volts all of the sudden?
  • Is my Arduino broken now?
  • Can I fix this?
  • How can this happen?
  • I think you should check your voltmeter as the 5v regulator of the nano will not be outputting ~7v – Bra1n Dec 23 '15 at 16:29
  • How did you connect it? Try a 5V source on the USB (just a phone charger or USB connection). – Paul Dec 23 '15 at 17:40
  • Just a stupid question: are you sure you are measuring from 5V to ground and not from 5V and 12V? Because 12V-5V=7V, and I think that's a strange coincidence.. – frarugi87 Dec 23 '15 at 18:22
  • Thanks for the comments. When Powering with USB from PC I have 4,2 V, but that is normal I think. I am 100% sure that I am measuring right and that the voltmeter is fine. :) Also one of the components that is connected with 5V burned through... so there is definately too much voltage on that pin! After the christmasholiday-break I will take a picture for proof ;) Also I tried another Arduino Nano, and there the Power is 5,02 V. So it seems the other one is definately broken. – Michael B Dec 23 '15 at 18:30
  • The 4.2V is a bit too low too. I guess the regulator is broken. – Avamander Jan 3 '16 at 12:28
3

Of course the 5V regulator on the nano can be faulty. Another possibility is the 5V decoupling capacitor. If it goes open circuit the regulator will oscillate and the mean output voltage will be near half the input voltage. Most regs have a minimum decoupling cap value specified.

|improve this answer|||||
  • Since I am using a cheap china-copy instead of an original Arduino, I guess this is exactly what happened. – Michael B Jan 12 '16 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.