2

I recently purchased an Arduino Mega 2560. As soon as I connected it for the first time with my macbook pro the led was blinking (default blink program). To stop the blinking, I uploaded an empty sketch to Arduino. Now the arduino is not showing up in serial port in any operating system. The LED is constantly on and not blinking. Please help

3
  • Are you using the same cable as before?
    – Majenko
    Dec 16 '15 at 22:22
  • Yes, using the same cable. Have also tried it with a different cable. Dec 17 '15 at 12:43
  • What does the Arduino IDE show for Ports? None?
    – marco-a
    Jan 17 '16 at 1:19
1

Did you try:-

  • Unplugging and reconnecting the board?

or

  • Holding down the reset button (on the board) during compile and then letting go when the Ide says "Uploading to ..."? (Make sure the sketch has a setup(){} and loop(){} so is not entirely empty)

If that doesn't work then ...

  • The pin13 on all the time with an empty sketch might indicate a hardware problem. Is anything connected to the board apart from the usb cable? Green LED simply means the board has power unless you are talking about the tx/rx Led's?

for windows users ...

  • Look in "Control Panel>Device Manager" to see if there is an exclamation mark against any devices, or "Unknown/Other" devices? If you can see the board but it has an error against it look at the properties to see if you can see what the error is. Re-installing the arduino ide will attempt to install the usb drivers again but they can also be found in the \drivers sub folder below the Arduino Ide.

  • If you can see an entry in control panel but it is not showing in the Arduino Ide try changing the port to a different COM number (right click>properties)

  • If you can't see anything in Control Panel try a different usb port on your computer.

  • Is the board connected directly to the pc via usb or via a usb hub? Make sure direct connect. If power externally make sure enough power.

2
  • I have tried unplugging and reconnecting the board and also pressing the reset button. As of now, the Green LED is ON and the ORANGE LED at pin 13 is constantly ON. Dec 17 '15 at 12:45
  • I've added some more suggestions and questions Dec 17 '15 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.