I have tried to get the Ai-Thinker ESP8266 working at all. If you hook it up to an Uno you have garbage returned no matter what the baud rate is. Tried softwareSerial on D3 and D4 (switching pins doesn't help) and over D0 and D1 with no sketch (to send AT commands directly to the device because softwareSerial wasn't working).

I'm using a logic converter from 5v to 3.3v to handle the voltage correctly.

I also know for a fact you can do that. I've done it a bunch with Bluetooth. HC-05.

NOTE: Pins in the wrong order won't return anything, in order to get garbage it needs to be wired correctly.

I also have a FTDI module that functions as another passthrough unit for this. It has a jumper for 3.3v to 5v and will stay on 3.3v as these units are unable to handle 5v.

I used PuTTY in order to view the boot information of this chip. On boot it returns this information.

So here's my issue.

ets Jan  8 2013,rst cause:4, boot mode:(3,7)

wdt reset
load 0x40100000, len 816, room 16
tail 0
chksum 0x8d
load 0x3ffe8000, len 788, room 8
tail 12
chksum 0xcf
ho 0 tail 12 room 4
load 0x3ffe8314, len 288, room 12
tail 4
chksum 0xcf
csum 0xcf

2nd boot version : 1.2
  SPI Speed      : 40MHz
  SPI Mode       : QIO
  SPI Flash Size : 4Mbit
jump to run user1

Ai-Thinker Technology Co. Ltd.


At the end of the day this invalid line means that the wifi information (from what I understand) is corrupted. It also refreshes this information over and over and WILL NOT accept AT commands so I can't seem to chase it down.

I am afraid that by attempting to update it if this kind of issue happens it will be bricked.

Both of these modules are opened today and I have tested another 8266 with similar results.

Any help would be appreciated.

  • Try SoftwareSerial on other pins. D0 and D1 is not a very good idea. These are the HardwareSerial pins. What sketch are you using? And how do you wire the ESP8266? 3V3 power supply? Commented Dec 14, 2015 at 10:13
  • In order. I used it to be a conduit to get to the chip directly so you don't have to use arduino code. Yes I know how bad it can be for live. I was using software serial to prototype the pins for when it worked. D3 and D4 with everything through a logic 5v to 3.3v converter. No sketch currently. I'm also using A FTDI usb to attempt to access it directly as stated in the original. I'm going to append this information.
    – Hyra Power
    Commented Dec 14, 2015 at 10:48
  • I have seen cause: 4 related to power issues on mine. Try giving it external power >500mA, that can be a power hungry little chip.
    – Butters
    Commented Dec 14, 2015 at 15:28
  • I'll give it a shot
    – Hyra Power
    Commented Dec 14, 2015 at 16:07

2 Answers 2


Alright so I figured it out. Thanks to user Butters for pointing me in the right direction.

The Arduino Uno DOES NOT have enough power to handle the ESP8266 itself. It needs a power source using a 5v to 3v stepdown chip. The 3v3 rail doesn't handle it by itself.


I don't know what this "invalid" means I am getting this on every boot but my device is working fine. I have tested downloading webpages and it's working. So maybe just ignore this. use cutecom it works there, didn't work in minicom maybe because of carriage return absent.

  • Invalid means your config is uninitialized or invalid
    – Hyra Power
    Commented Jan 8, 2016 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.