2

I use Arduino IDE 1.6.6 on Ubuntu 15.10.

Starting the Arduino IDE without using sudo fails for both:

  • uploading the code to the Arduino Uno
  • starting the serial monitor

The group I need to add my user to is called dialout:

myuser@mycomputer:~$ ls -l /dev/ttyACM*
crw-rw---- 1 root dialout 166, 0 Dez 12 17:57 /dev/ttyACM0

So I added myuser to dialout:

sudo usermod -a -G dialout myuser

Somewhere I read that I have to add myuser to tty as well, so I did it:

sudo usermod -a -G tty myuser

Though I still fail with the above mentioned when trying to use the IDE with myuser.

What do I have to do to get the IDE working with myuser?

2
  • 2
    Have you logged out yet? – Ignacio Vazquez-Abrams Dec 12 '15 at 23:26
  • 1
    @IgnacioVazquez-Abrams Oh, that was it. I had to log off and on again, something I rarely do. I feel so stupid now for not having tried that. Thanks for telling me! – Socrates Dec 12 '15 at 23:55
2

There should be a command like 'id' or something similar that will show the groups you are a member of. Run that to check that the new groups have taken effect – you may need to log out and then log back in.

The other thing to check is the group owner of the device itself (in /dev). that will also need to match the group you assigned to yourself. Also make sure that the device permissions allow group access.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.