So I've recently been playing around with my arduino uno, and today it completely refuses to communicate with my computer at all. I've tried using other cables, switched OS (Tried Windows 8.1 and Ubuntu 14.04), and tried on my laptop, none of them recognise the device at all.

From what I've read, this problem can be caused my a program on it with a Serial.println() frequently used, which I believe is the case here. The solution for this problem is according to other answers, to hold the reset button while I upload an empty sketch to the arduino. However, I can't do this, since the computer doesn't communicate with the arduino at all.

Any ideas what could've gone wrong, and how to fix it?

EDIT: Alright, the problem seems to have resolved itself... I have no idea what made it work, I was frustrated and went to bed last night, and today it works without an issue..

EDIT #2: Scratch that.. now I get this error when I try to upload a program to the arduino:

avrdude stk500_getsync() not in sync resp=0x00

The device does show up in Device Manager, so I tried installing the arduino drivers for it, but it gives me the error code 10. Windows automatically installs some serial driver for it, but any attempts of serial communication with the arduino fails.

  • What do you mean by "they don't recognize the device at all"? Jun 5 '14 at 21:00
  • The uno doesn't show up in the Device manager in windows, and in Linux I can't find any ttyUSB or ttyACM devices-
    – Pebbe
    Jun 5 '14 at 21:03
  • 2
    The state of the program on the '328 chip should not really effect the ability of the USB chip to present a functional peripheral interface to the computer. But if you hold down the reset button, then unless you somehow programed the reset disable fuse on the '328, it will be entirely out of the way and not bothering the USB chip in the slightest. Failure (even to be detected as a malfunctioning peripheral) with multiple hosts/operating systems at that point suggests hardware damage (or possible a USB chip which has come unprogrammed). On linux you should check dmesg when plugging, too. Jun 5 '14 at 21:29
  • I agree with @Chris. Is there any signs of damage on your board? Does it light up? Did it work before this? Do you know what sketch is on it currently? Jun 5 '14 at 21:30
  • There are no signs of physical damage on the board, and it lights up just fine. I'm not sure to what extent it worked before I tried uploading a program to it, it's been a while since I used it. I believe the sketch on the board was for reading the analog input of something, using Serial.println(). I don't have the sketch saved, as I just used it for debugging a while ago.
    – Pebbe
    Jun 5 '14 at 21:45

I had the same problem with my Arduino Leonardo. But when I kept the reset button pressed and plugged it into my laptop, it got recognised again. But since you're using an arduino uno it might also be the atmega16u2 which isn't working properly. If holding the reset button while plugging in the arduino to the laptop doesn't work, try to reset your atmega16u2 chip on the arduino. This is the chip which makes the communication from USB possible.

To reset the atmega16u2 follow this tutorial


I also got same problem and actually the problem was is of arduino. Arduino ATmega328 IC and ATmega16u chip was damaged . After that I replace ATmega328 Damaged Ic With new one reprogram it and program in ATmega16u chip and upload firmwares to ATmega16u chip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.