I think I broke my Arduino Uno as I was playing with it. I connected an ultrasonic range finder to it and uploaded a sketch to it. It was working fine until I accidentally touched the ICSP headers for the USB interface (the pins near the USB port). Now,everything is still working but my computer cannot detect it and it does not show up in the device manager or the IDE. Please tell me if it is broken and how to fix it.

BTW, I just bought it and just started using it after another Arduino had the same problem.

  • 1
    What have you tried? At the very least I'd try unplugging the Arduino and rebooting the computer (or in some way forcing a reset on the USB). The Uno may be particularly sensitive, but I've not seen a problem like this with any of my Arduino (and clone) boards. Do you live someplace where static electricity is a problem (I don't).
    – dlu
    Dec 1 '15 at 5:49
  • touching the ISP header or port should not have caused damage. Can your PC detect other usb devices on the same port?
    – dmSherazi
    Dec 1 '15 at 8:21
  • Get down to just the bare Arduino board, disconnect everything, and see what you get.. the Ultrasonic sensor could easily be pulling more power than your USB can supply, only about 500mA.
    – Butters
    Dec 1 '15 at 16:54
  • I have tried deleting the arduino software and downloading it again, I also unplugged the arduino and rebooted my PC but it. I also tried installing older versions of the IDE but it still did not work. My PC cannot detect any other USB devices on the same port. I tried disconnecting everything but it still does not work. Dec 3 '15 at 3:20
  • Try other USB port and another computer. If you wish you could try and reprogram the 16u2. If it does not respond it's dead but you can always either replace it or use the Arduino for things that do not require serial.
    – Avamander
    Dec 14 '15 at 21:16

Please tell me if it is broken and how to fix it.

See Have I bricked my Arduino Uno? Problems with uploading to board

Those tips may also help with fixing problems with your Mega (if you ever have them). ;)

Not the answer you're looking for? Browse other questions tagged or ask your own question.