I cannot seem to upload the simple blink program to my Arduino Nano. I keep getting the message:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03

What I have tried already with a lot of suggestions on Google. I have tried it on both a Windows 7 & 8 machine and with 2 different Nano's:

  • Set my Board to Arduino Nano
  • Set my Processor to ATmega168
  • Set my port to COM1
  • On windows 8 turned off driver signature
  • Installed the FTDI Driver
  • Checked my drivers in control panel
    • USB controllers says USB Serial Converter
    • USB Serial port says USB Serial Port (COM1)
  • Rebooted a Lot!

When I plugin the nano to the USB it starts blinking the L led 180 times a minute. When I start uploading, L blinks at about 80-100 times a minute, blinks the rx and then start blinking the L led fast again.

2 Answers 2


For me the problem was the selected "processor" type.

I had to change it to 328p (old bootloader).

Also, raise the IDE's verbosity, in order to have a nice progress bar when loading the sketch.

My specs:

  • OS: Linux Mint 18.3
  • Linux kernel: 4.13.0-37-generic
  • Arduino IDE: v1.8.5
  • board: the cheap and common Nano Chinese clone
  • USB to serial chip: CH340



If it's a new nano is probably the new version which has the 328 processor. Try switching to that.

Also does your computer make the windows "I just plugged something in" sound when you connect? Is the driver recognized?

Try this instead:

Set Board to Arduino Nano Set Processor to ATmega328 Set port to COM2 or any other device if recognized. Test to see if the Com1 stays if you unplug it. Try other usb ports as well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.