Im using the arduino Micro pro to read the data out of a temperature sensor (lm35). The program is compiling and NOT uploading, but when I try and open the serial monitor is says: Error opening serial port 'COM1'. (Port busy)

  • To be able to help you it would really help to know your development environment (what OS are you working on, how are you connecting to the serial port, etc.). The message suggests that another process using the serial port, it could be as simple as need to close and reopen your terminal emulator.
    – dlu
    Commented Nov 26, 2015 at 20:01
  • Im using windows 8.1, and im connecting to the serial port via usb.
    – M. Shaaban
    Commented Nov 26, 2015 at 20:04
  • How are you connecting to the serial port (what software are you using to received the serial data)? I don't do much with Windows, but I think the problem that you're having is that your terminal emulator is expecting to see the data on your COM1 port but you're actually transmitting the data over USB and a virtual serial port. The serial monitor in the Arduino IDE picks up the serial port from the setting in the menu Tools > Port (which is also used for your upload), but other programs will need it to be explicitly set.
    – dlu
    Commented Nov 26, 2015 at 20:09
  • the software is built in the arduino IDE. I edited the post the code is not uploading, only compiling.
    – M. Shaaban
    Commented Nov 26, 2015 at 20:18
  • COM1 is usually reserved for the built in serial port in the computer. Your USB serial port is more likely going to be COM3 or COM11, or even COM23 rather than COM1. Make absolutely sure you have the right COM port selected, and that you have installed the right serial drivers for your board.
    – Majenko
    Commented Nov 26, 2015 at 20:19

3 Answers 3


I've got an idea. Your board isn't being recognized. Try unplugging the arduino and see if Com 1 is still there. Sometimes it can recognize mice and other devices as Com 1 or 2 instead of your arduino.

On some of my development machines after everything settled out my devices will show up on Com 4 and 5 when I am working on two at a time.

If this is not the case go into the device manager and see if you can see the board listed.

I would also wonder if you have your sensor hooked to digital pins 0 and 1. These pins are used for your serial line on usb. So if you have anything such as a sensor hooked to them it may be generating data keeping the line busy instead of it being able to negotiate.

I had this happen when setting up hc-05 for the first time. I realized I had to keep the chip off while flashing or I would end up with errors or Com busy.

Please provide your pinout and basic information about the Com ports available on the ide. Also consider that you will need to specify the correct board as it will default to an uno.

Programmer not in sync issues generally occur because the board is recognized but cannot be written to for one reason or another.

  • the board has something plugged into digital 1 and 0 which are serial i/o pins
  • the board programmer is busy running your last batch of code
  • usb error


  • try a different cord
  • try unplugging potential wiring issues and see if it can be written to without anything on it
  • try holding down reset on the board until the board when you try to write to it until just after it finishes compiling to clear any potential programing issues

In my experience mega have a tendency to suffer from the last one.


Simple solution:

Close the arduino application and start again.

if still the issue persist restart your system. :)


I had a similar issue (port busy, RN42+Win 8.1) and find a solution by changing the usb bluetooth dongle of the computer.

The one which finally works for me was the Adafruit Bluetooth 4.0 USB Module (v2.1 Back-Compatible).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.