1

I am trying to upload a basic Blink code from my computer to Arduino Lilypad contains Atmega 328. While my Blink codes are uploading, FTDI 1402-C CN480661 FT232RL module is not responding to the Arduino IDE at the end of the process. So I couldn't upload any codes with this uploading method, I mean using FTDI modules directly.

This is how I do the connections:

enter image description here

This is my Blink code:

void setup() { pinMode(13, OUTPUT);}

void loop() {
  digitalWrite(13, HIGH);     delay(1000);            
  digitalWrite(13, LOW);      delay(1000);         
}

I chose AVRISP mkII as a programmer. ATmega328 as a processor. Arduino Lilypad as a board on Arduino IDE v1.6.6

At this point, I got this error:

avrdude: ser_open(): can't open device "\.\COM4": Access is denied

Windows's device manager says: USB Serial Port is attached to COM4, also Arduino IDE saw that.

enter image description here

I downloaded FTDI driver for Windows, but still, I can't upload any code into my Lilypad Arduino.

How can I use FTDI to program my Lilypad Arduino?

2

"Access is denied" this looks like you should at least restart your computer after you installed the FTDI driver if you have not already.

Run Arduino IDE as Administrator and also make sure you are logged into an Administrator account in your windows login.

If all this fails this means another application is using that com port you will need to figure out what could be using that com port another instance of Arduino IDE opened? Etc

If all else fails restart your computer with the usb unplugged, login, open arduino IDE and plug in your usb and select the com port.

Edit: You can also try changing the USB port you are currently using for another one, this will also change your com port to a new number

  • I tried but still not working. Should I use JP3 pins on Lilypad board directly? But, how can I program directly ATmega 328 ? What I need? – Bay Nov 23 '15 at 17:08
  • device "\.\COM4” looks like an odd name. I don't have an MSWindows system, but perhaps you know if it's an ok name. – James Waldby - jwpat7 Nov 23 '15 at 19:53
1

The error message

"avrdude: ser_open(): can't open device "\\.\COM4": Access is denied"

tells me that the error occurs when the Arduino IDE tries to open a connection to the FTDI adapter "serial port", long before the Arduino IDE actually sends anything through the FTDI adapter to the Arduino.

Have you read the Arduino Troubleshooting guide? The Arduino Troubleshooting guide recommends

Access to the Serial Port

  • On Windows, if the software is slow to start or crashes on launch, or the Tools menu is slow to open, you may need to disable Bluetooth serial ports or other networked COM ports in the Device Manager. The Arduino software scans all the serial (COM) ports on your computer when it starts and when you open the Tools menu, and these networked ports can sometimes cause large delays or crashes.
  • Check that you're not running any programs that scan all serial ports, like USB Cellular Wifi Dongle software (e.g. from Sprint or Verizon), PDA sync applications, Bluetooth-USB drivers (e.g. BlueSoleil), virtual daemon tools, etc.
  • Make sure you don't have firewall software that blocks access to the serial port (e.g. ZoneAlarm).
  • You may need to quit Processing, PD, vvvv, etc. if you're using them to read data over the USB or serial connection to the Arduino board.

If I were you my next steps would be:

  • Unplug the USB cable from my computer, and check the "Tools >> Serial Port" option. Usually when the USB cable is unplugged, that option is greyed out (empty list), but sometimes there is a few things listed. Remember that list.
  • Plug the USB cable from the FTDI back in (preferably in a different socket of the computer this time), and check the "Tools >> Serial Port" option. Do you remember the list from the previous step? There should be a new item on the list, representing the FTDI adapter -- pick that one.
  • I would unplug the FTDI from the Arduino Lilypad, and then tell the Arduino IDE to upload the sketch. Obviously with the Arduino airgapped from your computer it won't be able to upload the sketch, but does it give a useful error message?

  • Reboot the computer with nothing plugged into its USB ports. Plug the FTDI adapter directly into the Arduino Lilypad ("BLK" to "B", "GRN" to "G"). Start the Arduino IDE in Administrator mode. Make sure the board type is set correctly. Try to plug in the USB cable, set the Serial Port, and upload a sketch before any other program has a chance to grab that COM port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.