0

I recently dusted off an old Arduino Duemilanove to play with. I can connect it to my Mac laptop with the same USB cable I used previously and I'm able to monitor the serial port and see the output from the last sketch I uploaded (five years ago). Everything is unplugged from the board.

When I try to upload a new sketch, the Arduino IDE gets stuck on Uploading... indefinitely:

Using Port                    : /dev/cu.usbserial-A800eGZI
Using Programmer              : arduino
Overriding Baud Rate          : 19200

The board itself has the green PWR LED and amber TX LED on solid once the currently loaded sketch starts running. Initiating an upload causes the amber L LED to blink three times, then the RX LED blinks twice, and finally the TX LED on solid.

Here is the exact board: https://www.sparkfun.com/products/retired/666


My research into this issue produced many suggestions that have not resolved the problem...

I disabled the built-in FTDI driver:

sudo kextunload -b com.apple.driver.AppleUSBFTDI

And made sure the FTDI driver from ftdichip.com was loaded:

sudo kextload /Library/Extensions/FTDIUSBSerialDriver.kext

I tried csrutil enable --without kext against my better judgement and saw no change.

I also tried a completely separate machine -- my PC running Windows 10 -- and the upload hung there too.

I have tried timing the upload to coincide with a board reset, hoping to sneak my upload in before the current sketch starts running. I did this a lot and got no satisfaction.

I haven't given up yet; there are too many signs of life to think that it's unrecoverable. I'm looking for more suggestions on how to troubleshoot.

I have already ordered another Arduino -- hopefully I can use it to burn the bootloader on the Duemilanove.

0

Possibly the boot-loader baud rate in the IDE's boards.txt file is wrong. I have older (less than 6 years) '328p chips whose boot-loaders expect 57600 baud, but the boards.txt file in more recent Arduino IDE's try to talk to them at 115200 baud. I've had to duplicate the Arduino Uno entry in boards.txt and make one that specifies 57600 baud, to use these chips.

  • Thanks for your comment -- ultimately it led me to check everything again which uncovered my mistake. – Casey Nov 28 '15 at 10:17
0

The problem was that I selected ATMega168 when I should have selected ATMega328

facepalm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.