0

I am in a First Year Design class, and we are supposed to be making an autonomous robot. After hooking up some wind speed and temperature sensors to calibrate, I plugged in to my laptop (we have 2 arduino nanos) and ran a temperature code. I got the reading, but smelled something burning. Nothing was smoking, but I've found that when I plug my arduinos into my laptop, the light and the code indicate that they are not connected. This is odd because when I plug in the batteries, they show that the proper voltage is coming through, but they will still not connect to the laptop. Is it a problem with the micro-usb port?

I've included the code I'm using just in case that is cause for suspicion. It is notable that our instructors have written an API that allows us to code in Java for the arduinos.

public static void main (String[] args)
{
    robot = new ArduinoNano();
    robot2 = new ArduinoNano();
    robot.setPort("COM5");
    robot2.setPort("COM6");
    robot.connect();

    int reading = getThermistorReading();

    System.out.println("The probe read the value " + reading);
    System.out.println("In volts: " + (reading * (5.0/1023.0)));
    System.out.println();

    double temperature = (reading - 855.02) / -7.563;   

    System.out.println("Temperature: " + temperature);

}

public static int getThermistorReading()
{
    int sum = 0;
    int readingCount = 10;

    for (int i = 0; i < readingCount; i++)
    {
        robot.refreshAnalogPins();
        int reading = robot.getAnalogPin(3).getValue();
        sum += reading;
    }

    return sum / readingCount;
}

}

5
  • If you smelled burning, doesn't it maybe stand to reason that there might be a hardware issue? And yet you show us code in some unknown API that no one else here has a hope of knowing what it is. I suggest you re-think your question... – Majenko Nov 8 '15 at 20:59
  • Well yes, but I included the code just in case. The fact is that I can't find any hardware issues. There are no shorts in the wires, everything is grounded. I'm stumped with the hardware so I included the code in case someone could see a glaring mistake. – Will P Nov 8 '15 at 21:03
  • How can we tell? No one else but you and your tutor knows that API. Maybe you should SHOW us your hardware so we can be the judges of if there is something wrong or not. – Majenko Nov 8 '15 at 21:05
  • Did the magic smoke come out? If not, there's still hope. – Vladimir Cravero Nov 8 '15 at 22:13
  • 2
    Have you tried loading the 'Blink' sketch to just the Nano, without anything else attached? – CharlieHanson Nov 13 '15 at 11:41
0

First, did the Arduino continue to respond and operate after you smelled the burning?

Just because there isn't smoke doesn't mean you didn't kill something on the board.

If your Arduino is not responding, there are two possibilites I can think of:

  1. Your port is not working so simply switch to a different USB port

  2. Somehow your laptop must have sent a large amount of amps/volts to the circuit and burned it out. If you have a multimeter you can use the sound setting to test whether or not wires are burned out, and if your nifty with an iron/heat gun, you can replace the part. Or you could buy a new one.

enter image description here If the connection is good, you will hear a small beep. Oh, and these things don't work if there's a resistor in the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.