0

I am in the process of breadboarding an Arduino for a project and am using my FTDI Serial cable Adafruit FTDI Cable (tested working on Windows 7). I have also tested the breadboarded Arduino successfully on Win7.

When I plug the FTDI Serial cable into my Linux (Ubuntu 14.04 with Mint Desktop) laptop and the other end to my project (exactly as I did for Windows and it works for Win7), the Tools, Port is grayed out when in Linux.

I have tried running Arduino as root, with no success.

The output of : dmesg | tail is

sudo dmesg | tail
[  729.069015] usb 4-1.2: New USB device strings: Mfr=1, Product=2,     SerialNumber=3
[  729.069019] usb 4-1.2: Product: TTL232R-3V3
[  729.069022] usb 4-1.2: Manufacturer: FTDI
[  729.069024] usb 4-1.2: SerialNumber: FTF50VXW
[  729.487689] usb 4-1.2: USB disconnect, device number 4
[  729.615330] usbcore: registered new interface driver usbserial
[  729.615384] usbcore: registered new interface driver usbserial_generic
[  729.615432] usbserial: USB Serial support registered for generic
[  729.621997] usbcore: registered new interface driver ftdi_sio
[  729.622057] usbserial: USB Serial support registered for FTDI USB Serial Device

When I type "lsusb" into the terminal, there is no difference between when the FTDI is plugged in and not plugged in. I have tried switching ports with no success.

Any suggestions?

  • Is there a /dev/ttyUSB0 file entry with the cable plugged in? – Majenko Nov 7 '15 at 16:10
  • 1
    If it is not in the lsusb output, there should not be a device node - if there is, it is not connected to anything. By appearances, the USB connection has failed after briefly being recognized - try a different port, try it with the logic end of the cable not connected to anything, try it with a hub or without one if you were using one. – Chris Stratton Nov 7 '15 at 17:34
1

Check if the driver is loaded, in Terminal type:

lsmod | grep  ftdi_sio

If you get no answer then it's not loaded, load it using:

sudo modprobe ftdi_sio

I hope this helps.

  • lsmod | grep ftdi-sio shows that the driver is already loaded. – Ross Satchell Nov 9 '15 at 2:36
  • lsmod | grep ftdi-sio shows that the driver is already loaded. The device is appearing in the /dev/ folder Now when I try to upload code I get a avrdude out of sync error. I have confirmed I have the correct device (UNO) selected. As the Arduino is breadboarded, I press the reset button just as compilation completes (I use this same timing successfully when downloading from my Win7 machine). – Ross Satchell Nov 9 '15 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.