I installed the new IDE Environment 1.6.6 and I got this error when compiling a program. I am using an Arduino Uno

avrdude: ser_open(): can't open device "\\.\COM4": access denied

I need your help.

  • 1
    finnaly, it works after restarting my computer
    – zakaria
    Nov 5, 2015 at 11:26
  • 2
    If you have solved the issue, please post the solution as an answer.
    – Nick Gammon
    Feb 21, 2016 at 8:05

2 Answers 2

  • I think you used "Eclipse" and "Arduino" at the same time. so, I guess that a "com4 Port" conflict has occurred and the upload could not was done.

  • restart your computer and try to open "Arduino" first and upload. not open "Eclipse" at the same time.

I had this very same issue. I solved the problem by shutting down my outside cameras. Once cameras were off (the software) the program worked. It was the camera software that was using the port.

So if you have a lot of other software or equipment running in the background this may be your problem. Just try shutting down things one at a time. That's what I did until I found that the camera software was my problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.