1

I already asked my question in the Arduino Forum here: https://forum.arduino.cc/index.php?topic=353846.0 but got no answer so far. Thus I hope here might be people who have a hint for me.

Since I introduced some Ubuntu patches I suspect these patches are to blame. But frankly I have no clue.

Here is what I got:

If I connect the programming port then Arduino IDE 1.6.5 properly recognizes it as the programming port. Thus I assume that the cable is properly plugged in and the Arduino powered. In addition I get

> lsusb
...
Bus 003 Device 019: ID 2341:003d Arduino SA
...

> dmesg
...
 2074.703747] usb 3-3: USB disconnect, device number 18
[ 2076.678150] usb 3-3: new full-speed USB device number 19 using xhci_hcd
[ 2076.696405] usb 3-3: New USB device found, idVendor=2341, idProduct=003d
[ 2076.696407] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[ 2076.696409] usb 3-3: Product: Arduino Due Prog. Port
[ 2076.696409] usb 3-3: Manufacturer: Arduino (www.arduino.cc)
[ 2076.696410] usb 3-3: SerialNumber: 55437333537351F0F1D0
[ 2076.696501] usb 3-3: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[ 2076.697270] cdc_acm 3-3:1.0: ttyACM3: USB ACM device
...

So I assume the device is definitely connected.

> ls -l /dev/ttyACM3
crw-rw---- 1 root dialout 166, 3 Okt 17 09:56 /dev/ttyACM3


> grep dialout /etc/group
dialout:x:20:udo

So I assume that my user "udo" is authorized to access the device. Everything as it should be and as it used to be.

The patches that were applied are:

> grep "2015-10-16.* upgrade " /var/log/dpkg.log
2015-10-16 09:25:29 upgrade udev:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:30 upgrade libudev1:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:31 upgrade libpam-systemd:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:32 upgrade systemd-services:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:32 upgrade libsystemd-daemon0:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:33 upgrade libsystemd-login0:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:34 upgrade chromium-codecs-ffmpeg-extra:amd64 45.0.2454.85-0ubuntu0.14.04.1.1097 45.0.2454.101-0ubuntu0.14.04.1.1099
2015-10-16 09:25:35 upgrade libgdk-pixbuf2.0-0:amd64 2.30.7-0ubuntu1.1 2.30.7-0ubuntu1.2
2015-10-16 09:25:35 upgrade libgdk-pixbuf2.0-common:all 2.30.7-0ubuntu1.1 2.30.7-0ubuntu1.2
2015-10-16 09:25:36 upgrade google-chrome-stable:amd64 45.0.2454.101-1 46.0.2490.71-1
2015-10-16 09:25:41 upgrade libgl1-mesa-dri:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:42 upgrade libgbm1:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:43 upgrade libgl1-mesa-dev:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:43 upgrade mesa-common-dev:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:44 upgrade libgl1-mesa-glx:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:45 upgrade libgles2-mesa:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:45 upgrade libwayland-egl1-mesa:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:46 upgrade libegl1-mesa-drivers:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:47 upgrade libglapi-mesa:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:48 upgrade libopenvg1-mesa:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:48 upgrade libegl1-mesa:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:49 upgrade libgudev-1.0-0:amd64 1:204-5ubuntu20.14 1:204-5ubuntu20.15
2015-10-16 09:25:50 upgrade libhunspell-1.3-0:amd64 1.3.2-6ubuntu2 1.3.2-6ubuntu2.1
2015-10-16 09:25:51 upgrade libspice-server1:amd64 0.12.4-0nocelt2ubuntu1.1 0.12.4-0nocelt2ubuntu1.2
2015-10-16 09:25:51 upgrade libxatracker2:amd64 10.1.3-0ubuntu0.4 10.1.3-0ubuntu0.5
2015-10-16 09:25:52 upgrade linux-image-3.13.0-65-generic:amd64 3.13.0-65.105 3.13.0-65.106
2015-10-16 09:25:55 upgrade libsystemd-journal0:amd64 204-5ubuntu20.14 204-5ubuntu20.15
2015-10-16 09:25:55 upgrade ubuntu-release-upgrader-gtk:all 1:0.220.7 1:0.220.8
2015-10-16 09:25:56 upgrade ubuntu-release-upgrader-core:all 1:0.220.7 1:0.220.8
2015-10-16 09:25:57 upgrade python3-distupgrade:all 1:0.220.7 1:0.220.8
2015-10-16 09:25:58 upgrade update-manager:all 1:0.196.13 1:0.196.14
2015-10-16 09:25:59 upgrade update-manager-core:all 1:0.196.13 1:0.196.14
2015-10-16 09:26:00 upgrade python3-update-manager:all 1:0.196.13 1:0.196.14
2015-10-16 09:26:01 upgrade firefox:amd64 41.0+build3-0ubuntu0.14.04.1 41.0.1+build2-0ubuntu0.14.04.1
2015-10-16 09:26:04 upgrade firefox-locale-en:amd64 41.0+build3-0ubuntu0.14.04.1 41.0.1+build2-0ubuntu0.14.04.1
2015-10-16 09:26:05 upgrade flashplugin-installer:amd64 11.2.202.521ubuntu0.14.04.1 11.2.202.535ubuntu0.14.04.1
2015-10-16 09:26:06 upgrade gir1.2-gdkpixbuf-2.0:amd64 2.30.7-0ubuntu1.1 2.30.7-0ubuntu1.2
2015-10-16 09:26:06 upgrade gir1.2-gudev-1.0:amd64 1:204-5ubuntu20.14 1:204-5ubuntu20.15
2015-10-16 09:26:07 upgrade linux-headers-3.13.0-65:all 3.13.0-65.105 3.13.0-65.106
2015-10-16 09:26:12 upgrade linux-headers-3.13.0-65-generic:amd64 3.13.0-65.105 3.13.0-65.106
2015-10-16 09:26:15 upgrade linux-image-extra-3.13.0-65-generic:amd64 3.13.0-65.105 3.13.0-65.106
2015-10-16 09:26:21 upgrade linux-libc-dev:amd64 3.13.0-65.105 3.13.0-65.106
2015-10-16 09:26:22 upgrade thunderbird-locale-en:amd64 1:38.2.0+build1-0ubuntu0.14.04.1 1:38.3.0+build1-0ubuntu0.14.04.1
2015-10-16 09:26:23 upgrade thunderbird:amd64 1:38.2.0+build1-0ubuntu0.14.04.1 1:38.3.0+build1-0ubuntu0.14.04.1
2015-10-16 09:26:26 upgrade thunderbird-gnome-support:amd64 1:38.2.0+build1-0ubuntu0.14.04.1 1:38.3.0+build1-0ubuntu0.14.04.1
2015-10-16 09:26:27 upgrade thunderbird-locale-en-us:all 1:38.2.0+build1-0ubuntu0.14.04.1 1:38.3.0+build1-0ubuntu0.14.04.1
2015-10-16 09:26:27 upgrade liboxideqt-qmlplugin:amd64 1.9.1-0ubuntu0.14.04.2 1.9.5-0ubuntu0.14.04.1
2015-10-16 09:26:29 upgrade liboxideqtquick0:amd64 1.9.1-0ubuntu0.14.04.2 1.9.5-0ubuntu0.14.04.1
2015-10-16 09:26:30 upgrade liboxideqtcore0:amd64 1.9.1-0ubuntu0.14.04.2 1.9.5-0ubuntu0.14.04.1
2015-10-16 09:26:33 upgrade oxideqt-codecs-extra:amd64 1.9.1-0ubuntu0.14.04.2 1.9.5-0ubuntu0.14.04.1
2015-10-16 09:26:33 upgrade python-tz:all 2012c-1build1 2012c-1ubuntu0.1

I checked with Arduino 1.6.0 (which worked till yesterday) and then installed Arduino 1.6.5. Arduino 1.6.5 also fails to upload but definitely recognizes the port. What I get though is the message "Forcing reset using 1200bps open/close on port /dev/ttyACM3..." and then the upload is stuck. To be more precise bossac gets stuck and puts 100% load on one of my cores.

I also installed bossash. If I issue a "scan" command bossash will properly detect the correct port. However I will also lockup with 100% load on one of the cores. So the issue is probably not related to the IDE at all but to bossa.

Has anyone a hint how I might fix this? That is why bossac lock up and how to get it to upload again as it did before?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.