0

I know that there are plenty of questions related to relays, but I have to ask. I am trying to sort out the issue and spend hours reading but cannot make progress.

I have SainSmart 2-Channel 12V Relay Module for Arduino and wired it according to picture.

SainSmart 2-channel relay

Arduino UNO R3 board is powered from 12V plug external power supply. I take that 12V to power JD-VCC on relay (from VIN). Arduino 5V is used to power optocoupler circuitry.

I want to use to power 12/24/220V devices (on picture I wired 6V battery for troubleshooting).

So, when I set PIN7 to LOW i would expect that fan spins up. LED on relay goes RED, so I expect it is sign that relay is activated. However, fan does not power on. When I bring PIN7 to HIGH, I hear click; LED goes OFF. I assume it deactivated relay. All the time I have 6V on voltmeter.

What I am doing wrong? I really tried to find answer around, but either I do not see or it is not so obvious.

Thank you,

WIRING

  • Are the relays 12V or 5V? – Majenko Oct 15 '15 at 12:43
  • So the fan never goes on? – Gerben Oct 15 '15 at 12:55
  • It should be 12V, on relay is written G5LA-14 12V DC. No, the fan never goes ON. – politkom Oct 15 '15 at 14:30
  • I am trying to post image of relay, could not find option. First time user. Now I have to go for few hours. – politkom Oct 15 '15 at 14:35
  • Did you disconnect the jumper between JD-VCC and VCC? – Gerben Oct 15 '15 at 15:45
1

Lets troubleshoot this circuit:

  1. The circuit diagram you put in your question shows a wire creating a short across the relay coil. Check this, as this will definitely stop your fan from spinning. However, I assume this is an error in the diagram.
  2. The picture on the website shows a jumper link between VCC and JD-VCC. Make sure this is removed.
  3. Check that the fan works when you power it directly from the 6V battery. The fan may work only at a higher voltage or run off of AC voltage. Also, the battery could be flat - measure its voltage when it is under a small load.
  4. Drive the input circuitry directly off of 5V. That is connect VCC to 5V and then directly connect IN1 to GND. Open circuit the IN1 input to turn it off. Check that this direct driving opens and closes the relay contacts.
  5. Check the 12V supply. Does the voltage drop significantly when the relay pulls in or out? Does it have enough current? "Each [relay] needs 15-20mA Driver Current" Measure it using your DMM in ammeter mode.
  6. Check your wiring is correct. It sounds simple, but you will be surprised by how many times the wiring is the cause of the problem.
  7. Measure the resistance of the relay contacts in both the open and closed states. Arcing or poor manufacturing can be causes for the contacts to not function as intended.
  • Add a comment if there is something I have forgotten... – sa_leinad Aug 24 '17 at 14:38
0

Looking at what I assume is the same module on the Sainsmart website it looks like the relays are 5V. That means the 12V you have pumped into them has made the Magic Smoke™ escape.

Throw them away, buy some new ones, and next time don't put in more than twice the voltage it needs.

  • I tried 5V using JD-VCC jumper, but did not work. Not sure whether I did hear clicks when releasing relay. Then I read somewhere that JD-VCC can be used to provide supply to relay and completely isolate coil form GPIO (maybe even here but in Raspy thread). Which is exactly why I bought them, optocoupler. I checked relay module and it is OMRON G5LA-14 12 V. So, I connected it. I do not know how they can make 12V for coil from 5V i send from Arduino. There is no credible user guide, so in a mean time I burned out brand new Mega 2560 for this. Such a pity. – politkom Oct 15 '15 at 13:40
  • Still, I am happy. I tried 12V, but I planned to manage 220V devices using these relays. When I saw that there is no plenty documentation I decided not to risk. – politkom Oct 15 '15 at 13:46
  • Ok, so if that module has 12V relays on it then it's not the same one I am looking at. Is this the actual module? sainsmart.com/arduino/arduino-components/relays/… If so then you have called it the wrong thing which caused confusion. – Majenko Oct 15 '15 at 13:51
  • It is actualy this one. sainsmart.com/arduino/arduino-components/… – politkom Oct 15 '15 at 13:54
  • @politkom Ok, so I have helped you out and edited your question for you so it has the proper information in it. You might want to look at the schematic - it is meaningless with that module since it doesn't tell us what the jumpers on that board are supposed to do. If you can't find the real schematic then I suggest you grab your digital multimeter and trace it through and draw the schematic yourself. – Majenko Oct 15 '15 at 13:59
0

Remove the wire from the collector of your transistor and 12VDC, it should work fine. It is possible you blown the opto coupler and transistor.

  • First of all the schematic is the one of the board, not one of his circuit, so it is just an error in the drawing, not on the circuit. Then if he did really short it the effect would be to blow (maybe) the transistor, not the optocoupler.. – frarugi87 Sep 28 '17 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.