I'm trying to get a simple TX/RX pair to work. I've got identical Nanos and I'm using the example from: http://arduino-info.wikispaces.com/Nrf24L01-2.4GHz-HowTo

I followed the advice about adding a cap across the Vcc GND on the nrf board, and added a 10uF electrolytic to both.

I still haven't received a packet yet, and I wondering how to eliminate the power supply as a cause. I scoped the power pins, and even without a cap I got about 250mV of ripple. With the cap it goes down to about 100mV. Is this within tolerance? What kind of caps does anyone else use, and has anyone scoped the result to see where the threshold lies?

Aside form that, are there any other clever ways to debug this issue?

Update 20160122. I finally tested using those cheap piggyback 3.3v regulator boards that plug straight into the nrf board. Works perfectly, not one lost packet over 5000 packets sent. Interestingly, the RX side appears to be the fussy one. Thanks to everyones' suggestions. For a total combined cost of about 4$ per node, I have a great wireless TX/RX solution.

  • Having two units too close to each other can cause problems. Either have them apart, or lower the transmit power.
    – Gerben
    Commented Oct 12, 2015 at 12:09
  • If you have, try a bit bigger capacitors. Capacitors on my modules are 100uF and they work.
    – Avamander
    Commented Oct 13, 2015 at 17:35
  • In the end I put a scope across a 10Ohm resistor in series with the nrf power leads to see what kind of current draw the TX was using, and also played with adding different caps. You're right, the recomended 0.1uF to 10uF doesn't seem to be enough. I get best results with a 470uF electrolytic. But I still get about 20% packet loss across my desk. And the voltage on RX side is very noisy. Both boards are being powered by the 3,3v nano on-board regulator. I've ordered some piggyback regulator board for the nrf so I'll test with those when they arrive.
    – mjk
    Commented Oct 14, 2015 at 21:48
  • 20% packet loss? Whoa, what are you using to power the regulator? Have you tried decoupling the power supply even more?
    – Avamander
    Commented Oct 15, 2015 at 14:15
  • Right now I'm using the Nano on board 3.3V reg for both T and RX. They are plugged into the USB port on my laptop. The TX side seems to be quite stable. The RX side shows lots of noise, with Vpp of about 100mV. Strangely, using PowerOff, delay and PowerOn to try to limit the current draw on RX doesn't seem to have any effect. Whereas decreasing the retries on the TX shows a corresponding decrease in power consumption. And 20% loss is my best so far. If I use a 10uF cap I often get no packets at all.
    – mjk
    Commented Oct 15, 2015 at 23:38

1 Answer 1


I would suggest using a different power supply, that appears to be your problem. 250mV is 1/4 of a volt, that is a lot of noise/ripple. I am assuming it is ripple from the AC mains. The series resister is way to large, try something about 0.1 ohm. Also put a filter cap on the load side of the resister. If you have high frequency noise add a 0.01 cap that will help. Be sure the grounds between the units are solid.


I have a feeling it is narrow fast rising spikes. If so the odds are very high it is the power supply. Can you try an analog one and see if the problem goes away? Try adding more bulk capacitance, at the rate of at least 1000uF per amp.

  • Thanks for the suggestions. The ripple is of a much higher frequency than mains hum. I'm collecting together a few ideas and I'll test them when the alternative power supplies turn up. I'm pretty sure it's the receiver that is having trouble. I'm also not ruling out interference from other traffic in that frequency.
    – mjk
    Commented Oct 19, 2015 at 3:03
  • @mjk It's also worth mentioning clone modules have worse receiving ability. Check if you have original modules, it might solve your issue.
    – Avamander
    Commented Jan 20, 2016 at 19:30
  • Thanks for the info. I tested using the 3.3v regulated piggy back boards last night, and they worked perfectly.
    – mjk
    Commented Jan 21, 2016 at 22:22
  • @mjk So you've fixed your issue?
    – Avamander
    Commented Jan 22, 2016 at 22:02
  • Yes, as far as I can tell, the issue lay int he power supply. I tried direct from the Arduino 3.3v regulator. I also tried an external 3.3v supply from a bench supply, and all sorts of variations of caps to filter ripple. Funny thing is, as far as I can tell, the piggy back board has the same 3.3v regulator as the arduino. Same package size at least, with a few smd caps. Yet the result is clear. for the extra buck, I'll be buying a piggy back board with each radio device. All I have to do now is test the range, but for my current app, I only need <10m max.
    – mjk
    Commented Jan 24, 2016 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.