0

I have an arduino uno Rs board and when connected to USB the board is dead. Yet when connected to the external supply the board will come to live. Power LED on and led near pin 13 blink on and off all time. I tried another computer and other new usb lead. Still computer will not see the board. When usb lead is on checked the 5 volt on the board and it is ok. Even checked the usb lead with multi meter and all four connection are ok Can you give me some advice


1.Yes I bought the new board from different source but still waiting for it to arrive. 2. My clone board Arduino uno using microcontroller Atmega329P-PU and interphase chip Atmega16U2] 3 but the video link is still of help as my new board is as the one shown in the video. Will use it late. Great!!! There should be a similar explanation for the one I have in the pictureUno board as descripted

3
  • When connected by USB, does the LEDs light up? Or is it only that the PC cannot find it?
    – Paul
    Oct 13, 2015 at 13:39
  • Using the usb only board to computer the board is dead no led comes on and computer does not see the board. Only when external 12v is applied in the dc socket the power LED comes on and led near pin 13 start blinking. But computer still does not recognize the board.
    – MBE200
    Oct 15, 2015 at 6:24
  • So basically two problems? Not being powered by USB AND not being recognized by PC? You should check if these things are related. If it never worked before, it might just be a bad board. You can try programming with a regular AVR programmer.
    – Paul
    Oct 15, 2015 at 6:58

3 Answers 3

1

Does the Arduino show up at all in device manager or in mac/linux.(not sure what you are using)Is your board authentic or a clone? Did this happen the first time you plugged the arduino in or after uploading sketches etc? I had screwed up my firmware for my board that acted similar to what you describe.(I was trying to flash a different firmware) Eventually i ended up reflashing the right firmware and it went back to working again.Maybe it's that, maybe it isn't.

2
  • I am using window 7 . It says on the board made in Italy but I doubt it. I think it is a clone due the power led is red not green and the small chip near the usb is green not brown. But a lot of these boards work. Yes this happened first time I plug the usb in. How can I reflash the right filmware. I like to try your idea. Maybe it work. Thanks
    – MBE200
    Oct 11, 2015 at 5:10
  • I think you will need a working Arduino / usbtinyisp v3.0 or a usbasp programmer (I'm sure there are more options but that's what i know that works) I have read where people who bought the clones had faulty flashes on them when they get it. Also the chipsets are different so you may have to do some research on that. The link that 'Matt' Posted would be a good starting point in learning how to reflash firmware.
    – Woolfy
    Oct 12, 2015 at 3:57
1

I had a similar problem. though it was easily solved but not obvious.

I couldn't connect my nano to the computer, but other devices worked fine. After a while other devices started to be faulty such as portable hard-drives and my CC3D flight controllers. After a cable replacement all the items started working again even the Arduino that i otherwise had discarded as broken.

It might not be the solution you are looking for but im leaving it here in case others comes for a solution.

0

You are happy the lead is ok. Good.

Can you test another Arduino on the PC? (Is it a driver issue?)

Can you connect to the serial pins on the Arduino and read the console output, is anything coming out on USB? (Is the USB socket on the board broken?)

Have you selected the right board type on the ide? (I know it's a dumb question but...)

3
  • I only have one arduino uno and bought another but still waiting for it to arrive. But if this is a driver issue a the computer still should recognize the board. When a new device is insert in the computer it should detect and say in the device manager "unknown device" up to my little knowledge. I must find a way how my computer see this new device.The usb on the board is solid and measured the 5volts the ok. But do not know how to measure date. maybe will put an oscilloscope.
    – MBE200
    Oct 11, 2015 at 5:40
  • Did you buy the second board from a different place? Otherwise you may have the same problem. Oct 11, 2015 at 6:42
  • I don't agree with the title of this, but this MIGHT help instructables.com/id/How-to-fix-bad-Chinese-Arduino-clones Oct 11, 2015 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.