0

I have followed all the instructions provided on http://allaboutee.com/2015/01/20/esp8266-android-application-for-arduino-pin-control/

I have got the correct setup, I have got the message "Server Ready" in the serial monitor, i have an app similar to this, means the only thing i have done different from the web page is removing two buttons from the app.

But then also whenever i use my app to send request parameters to arduino it says "connection to 192.168.x.x:xx refused" , when i put the same ip and port in chrome, it says Server not reachable, the website may be down, What to do ? , Please help...

  • First of all check that your ESP is connected to your WiFi network, to do this go to your router and check that your device got that IP address. Only when it shows up at your router you'll be sure that it is available on the network. – ProgrammerV5 Oct 7 '15 at 15:54
  • i did that already, my router homepage shows the same ip address on which i am trying to send the http request – vedang_joshi Oct 7 '15 at 16:06
  • Ok, then that means that your ESP is connecting to the WiFi network, but that doesn't mean that the web server is up and running. Arduino is showing up the Server Ready string but that doesn't mean that the actual ESP is actually running. Where the line if(esp8266.available()) // check if the esp is sending a message { create an ELSE statement just to check if the .available is returning false (meaning that the ESP is not there for Arduino. – ProgrammerV5 Oct 7 '15 at 16:11
  • absolutely, you are right, it is not actual sending anything, i just created a else statement making it print "no message send" and my serial buffer got filled up with the Same. Now, we now the problem, now the job is half done, what to do next. – vedang_joshi Oct 7 '15 at 16:22
  • That doesn't work – vedang_joshi Oct 21 '15 at 16:27
1

The ESP module is not that difficult to work with, if you send the correct parameters to it AND you have the correct power it should work as expected.

My main suspicions will be cabling (just triple check that connections are as expected) and power source (the ESP is VERY power hungry, if you are powering the ESP from the Arduino that is your problem, you need a very good and stable power for the ESP to work (it might show up on your network but will not have enough power to actually send anything and it will disconnect (that will still show up on your router, it depends on how fast it connects/disconnects but won't be able to send anything).

This link can provide some good information about this subject:

http://bbs.espressif.com/viewtopic.php?t=133

  • But, just now, i uploaded bare minimum and then opened the serial monitor and typed the commands one by one it worked out, the server was ready and it was also accepting my http request, but how can i compile all those commands in the sketch. – vedang_joshi Oct 7 '15 at 16:44
  • 1
    Ok, progress. What exactly did you do? how did you "uploaded" those commands? Using Arduino? Also, you didn't answer my question, how are you powering your ESP? – ProgrammerV5 Oct 7 '15 at 16:54
  • i have connected ESP to 3.3v on arduino and then i uploaded a empty sketch, then opened the serial monitor and typed in AT and got response OK likewise i typed in each AT command and the server was setup and it responded, but you know serial monitor has it's own limitations – vedang_joshi Oct 7 '15 at 16:58
  • Ok, I understand that you think it worked (in fact you saw it) but the BIG difference here is power. If you send those commands one time it might not do a lot but as soon as you start sending other commands the ESP will start to consume more and more power (the library on the Arduino is not doing only the send of those commands but much more) and that's when the ESP just dies, it doesn't have enough power to stay up. – ProgrammerV5 Oct 7 '15 at 17:00
  • i have a malfunctioned arduino board but it can supple enough power, should i add that also keeping the present arduino as it is – vedang_joshi Oct 7 '15 at 17:04
-1

I had the same problem and it worked when I disconnected my phone from 3g/4G.

New contributor
Friend is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.