0

I have the Dagu Mini Driver board which is based on the atmega8 and I uploaded the code here. It uploaded perfectly and I wired 4x AA pack to the battery terminals making sure to observe polarity.

I then attached two DC motors to the ML and MR pins just like it said in the picture. I turned the board on, making sure the switch was set to on also.

The red light lighted up and the blue light flickered for a second. The motors did not move. I tried different motors. To check if it was a corrupt bootloader I tried to upload the hello world blink sketch. That worked perfectly.

I got my multi-meter out and tested the wires I was using...all good! Tested the battery...6.31v! That's within specs. I have the jumpers correctly inserted on the D7 - 10 pins. Here's my setup: http://blog.dawnrobotics.co.uk/wp-content/uploads/2013/11/circuit_diagram.png

What in the world could be wrong? The code is supposed to make it turn in a rough square. I checked it over and over and it looks right. Any ideas?

2
  • What +V selector are you using? Battery or 5V. My guess is that you have it in the 5V setting and the regulator cannot driver the motors. The load is too high. generationrobots.com/media/… – Mikael Patel Jan 24 '16 at 21:09
  • I had one too work perfectly ....I think you codE is wrong... – user19404 Mar 19 '16 at 8:47
0

This is a generic debugging advice, but maybe it can still be of help: have you tried driving the led from the loop, to check that it doesn't get stuck for some reason?

Other thing you could do is to get the datasheet of the motor driver, find out the inputs from the ATMega and see how they look like. At least that would allow you to bisect the problem answering the question: "Does the ATMega generate the expected signal?"

2
  • It looks to me like the "motor driver" is a pair of H bridges built out of discrete MOSFETs. Hard to work out which one of the 14 MOSFETs is which. Simpler to look at the digital IO pins that are documented as the control pins for the bridges. – Majenko Sep 26 '15 at 19:55
  • If you mean the "hello world" blink sketch that blinks the D13 LED, I uploaded that and it works. I'll look at the data sheet. – NULL Sep 28 '15 at 12:30
0

Switching the selector did not help. I received a new one which worked perfectly following the steps from before. Apparently the issue was hardware related, possibly a cold solder joint preventing the motor driver section to work while still letting everything else continue normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.