0

I need to hard reset (or seriously breathe life into) a stuck Arduino clone (Sunfounder UNO) which doesn't get recognized by Windows (error 43) after installing the wrong sketch. I am using the latest Arduino toolset and, before today, the setup was functional.

The problem is probably that I am writing to the serial in the setup() section like this:

void setup() {
  pinMode(a0, OUTPUT);
  pinMode(a1, OUTPUT);
  pinMode(a2, OUTPUT);
  pinMode(b1, OUTPUT);
  pinMode(m0, OUTPUT);
  pinMode(m1, OUTPUT);
  pinMode(m2, OUTPUT);
  pinMode(OK, OUTPUT);
  pinMode(KO, OUTPUT);

  pinMode(carry, INPUT);
  pinMode(result, INPUT);
  delay(1000);

  Serial.begin(9600);
  Serial.write("Arduino Tester v. 0.1\n");
}

Arduino seems to be running the code. The problem is that Windows doesn't recognize it and doesn't set up a COM port for it.

So: i'd like to nuke it and restart from scratch.

How is this done?

2
  • What kind of Arduino clone? What USB interface does it use? – Majenko Sep 13 '15 at 21:34
  • @Majenko updated the question – Sklivvz Sep 13 '15 at 21:35
2

The word "clone" immediately rings alarm bells.

Firstly, for a "normal" Arduino (like an Uno, etc) the sketch cannot influence whether Windows detects the board or not. All that is handled by a completely separate chip.

A lot of the cheap clones these days are coming out of China with a really really cheap USB serial adapter chip. These barely work at the best of times. Looking at the pictures I have found of your clone (the manufacturer's site is considerably lacking in any information whatsoever) it doesn't look like it's one of those chips, but one never can tell.

If they have followed the reference designs for the Arduino then it will be an Atmel ATMega32U4 (IIRC) chip that deals with the interface to the computer. That has firmware of its own on it, and if that has become corrupted (very unlikely) or damaged (possible) then it could cause it to not be recognised. If that is the case the in the former instance (corrupted) you will need to replace the firmware on it. For that you will need either a hardware ICSP programmer or another Arduino. In the latter instance you're stuffed, since you would need to replace the chip.

As I say that is unlikely.

Instead your problem is most likely actually with either Windows or the USB cable. You may need to remove and reinstall the Arduino drivers, or try a difference USB cable. Also try your "Arduino" on another computer.

9
  • Interesting. The USB chip is Amtel AT MEGA16U2. I've tried on a completely different system (macbook air which also was working before today) and it didn't make a difference. – Sklivvz Sep 13 '15 at 21:46
  • Solved: It was the cable. – Sklivvz Sep 13 '15 at 21:52
  • The 16U2 was used on the R2 - they upgraded to the 32U4 for the R3 IIRC. – Majenko Sep 13 '15 at 21:56
  • +1 for guessing it was the cable, Makenko. I just want to comment that I found some USB cables (eg. to a USB light or fan) do not have data wires. That is, to save money, they only use two wires, which carry the 5V power and ground, and omit the A/B data wires. Naturally such cables do not work as data cables, and therefore plugging into a PC using one achieves nothing. – Nick Gammon Sep 13 '15 at 22:06
  • @NickGammon It wasn't a guess - just weighing up the balance of probability - probably skewed slightly in (dis)favour of Windows failing, but that's personal bias... – Majenko Sep 13 '15 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.