1

I have a 2008 Mac that hardly ever crashes. But from time to time (not always) it crashes (the whole computer shuts down as if the power has been cut off) when I plug in an Arduino via USB.

What could cause this?


I've done some testing and the constant in when this occurs seems to be a cheap PIR sensor from eBay. It works some of the time.

Should I get another sensor? Or is there something about PIR sensors that makes them prone to this? It has a lot of caps... Is there another kind of motion sensor?

11
  • A faulty cable or board. – Ignacio Vazquez-Abrams Sep 12 '15 at 6:00
  • What sort of fault? – futurebird Sep 12 '15 at 6:02
  • Which Arduino? Genuine, clone or knock-off? I ask because some of the cheaper ones require unusual USB drivers. – Nick Gammon Sep 12 '15 at 6:12
  • This has happened with multiple micros, from genuine one to a nodemcu esp8266... I'm thinking it's the long micro usb cord that came with my headphones... are short cords better? – futurebird Sep 12 '15 at 6:16
  • 1
    @futurebird Power supply for your potentiometer? – Avamander Sep 14 '15 at 20:23
2

It could possibly be that there is a fault that is causing a short circuit. This short circuit could be in the board itself or the USB cable that connects the Arduino. The USB port on the Mac should have protection to protect against a short circuit. Your comments have indicated that you have tested for a short and found none - but this is helpful for others that are looking for a solution.

In your comments you mention that you solved this by changing the positive rail of your potentiometer from 3.3V rail to the 5V rail.

1

I had this problem with a Chinese knock-off of an Arduino Nano -- looks like it was actually because I had previously installed some CH341 drivers that no longer work with Sierra.

Removing those drivers (sudo rm -r /Library/Extensions/usbserial.kext) stopped the crash (full computer shutdown when I plugged in the Arduino, even through an externally powered USB hub), but unfortunately my Mac doesn't seem to recognize the Arduino.

It looks like there is a newer version of the driver (1.4, 2017-01-11, downloadable from here), or the 1.3 version is available as a homebrew cask if you tap that repo.

I am a little wary about installing a driver from a random Chinese site. If you want, you can unzip the driver and unpackage the .pkg file with pkgutil --expand package-name.pkg destination-folder. There are a couple subfolders including a Payload that you can inspect a little with zcat -- way over my head.

Alternatively, it looks like this repo may have a C++ driver that may work.

0

As n8henrie said this is an issue regarding drivers with Mac OS. I updated to Mac OS Mojave (Full disclosure I run a Hackintosh system) and plugging in the arduino nana would cause a massive kept stall causing my computer to loop (if playing a video it would loop back and forth) and I’d need to turn off the PSU in order to successfully boot. However by deleting the current drive I used (CH341) the board would no longer do this (note- I tried 3 boards from different sellers, with 1 genuine and 2 Chinese) in High Sierra this did not happen however

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.