0

I just bought a new Arduino Leonardo Eth, and, it was working perfectly.

I probably uploaded about 30 different sketches, and it did everything as expected.

The basic sketch was using the fade demo on pin 9 to ground with a LED attached.

I was then curious on how long the unit takes to restart, so, I unplugged the USB and put it back in.

When it started back up, the LED was on solid. I then restarted it again, and I honestly can't remember the state of it.

When I plug it in, it gets detected in the Arduino application and I see the port, but, after about 20 seconds, I get a popup on Windows saying about a malfunctioning USB device.

Pressing reset on the Arduino or unplugging/plugging it back does the same - I get about 20 seconds, and then it "goes bad".

Even if I am real quick in the IDE, or press restart after compiling/before upload, it just hangs.

I'm really annoyed with myself if I did break it, but, I'm not really sure what else I could have done differently... after all, there isn't an off switch.

Does anyone know what I have done, and, is there anyway to fix it?

  • Can you communicate with it via ISP? – Ignacio Vazquez-Abrams Sep 8 '15 at 17:51
  • @IgnacioVazquez-Abrams I just read another post about bricked Arduinos, and I am going to give that a shot... Honestly, this is my first official arduino device - I have purchased a few low end Arduino Micro compatible units, but, I am not sure that they have the ISP function... This is my first experience with arduino/electronics, and I do feel a little out of my depth! ... I was hoping there is a certain combination of restart button pushes to factory reset or similar! I'm traveling at the moment, but will try again normally and look at ISP when I get home – William Hilsum Sep 8 '15 at 18:00
1

You should be able to use my board detector sketch on one of your other Arduinos to check out the problem board.

See also Have I bricked my Arduino Uno? Problems with uploading to board

Also my bootloader uploader sketch will reflash bootloaders on quite a few devices. I'm assuming that the "Arduino Leonardo Eth" has the same bootloader as the Leonardo.

Hmmm - I see that the "Arduino Leonardo Eth" is from Arduino.org, not Arduino.cc. The bootloader is probably slightly different. I'm really not an expert on what those boards use.


Before worrying too much, try the approach of holding down Reset and then uploading a sketch, letting go of Reset as the sketch starts to actually upload.


Comment by William Hilsum

I didn't realise there was a difference between .org and .cc, and, I guess by using the leonardo template from .cc, I broke "something". The moment I downloaded the IDE from .org, & uploaded with the eth template , it worked flawlessly. I guess there are some changes between leonardo and leonardo eth. I wanted an arduino with ethernet, so I didn't need a separate shield. No idea if I picked the right "side" after reading all the crap with cc vs org!

That is very annoying that the split of the Arduino camps now produces a support nightmare for people who just want to use their virtually identical products, but have to go through this.

Thanks for the update.

  • Sorry to sound dumb, what's the difference between Arduino.org and Arduino.cc? The Leonardo Eth was from a trusted supplier (Farnell) and I didn't know there was a difference here! I thought it was just one was a community and one was the company... Anyway, as for the "cheap" Arduinos, I just bought them from eBay and have never actually used them, ... Being honest, I'm not even really sure how to right now/there is only headers/no pins, so, I have to look in to that when I have more time! I'll give the reset thing a try though. Thank you.... – William Hilsum Sep 8 '15 at 22:44
  • It's worth saying, I have a theory... I read from the Arduino troubleshooting page that it doesn't auto start if it gets a signal - I am wondering if the first time I connected, it was simply "empty" and worked, the second time, my machine/vmware/something intercepted the call and tried to do something causing it to pause. This doesn't explain why it gets detected and disconnected straight after uploading though. – William Hilsum Sep 8 '15 at 22:46
  • The Leonardo presents as a USB device initially so you can upload a sketch to it. After a certain time (mine took around 9 seconds) it exits the bootloader, and that USB device "goes away". Then it runs your sketch. If your sketch does not open Serial, a keyboard or mouse, then it is no longer a USB device. So this is expected behaviour. – Nick Gammon Sep 8 '15 at 22:53
  • what's the difference between Arduino.org and Arduino.cc - various of the original Arduino founders have had a dispute about who owns the "Arduino" name. See, for example: Arduino Wars: Group Splits, Competing Products Revealed? – Nick Gammon Sep 8 '15 at 22:55
  • Thanks so much, and found a really good answer on here shortly after writing that... I used the Arduino download from cc, I used Leonardo as the base... I just downloaded it from .org and now have the Leonardo eth template - I am guessing that as much as it worked, it may not have done a lot of good! I swear the .cc download only had ~2 drivers, the .org one needed around 10 - I hope it hasn't screwed anything up on my pc... – William Hilsum Sep 8 '15 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.