I am trying to get an Arduino Mini (R5, mega 328p) working.

Just connecting it to power has following effect: the on-board LED lights up. It's the power-on-led, I presume.

Since other Arduino devices often come with the blink-example pre-flashed I hooked up a LED to pin 13 - result: no blinking.

Curiously, connecting the LED to pin 12: blinking

Does the Mini come pre-flashed with a blink 'sketch' that blinks pin 12 instead of 13?

To test uploading I've connected it to an Arduino USB2Serial module. The module is labeled with 'made in Italy' and has printed 'USB2SERIAL LIGHT' on it where the LIGHT is overwritten with a blue marker.

I've connected it like described in the arduino mini guide.

In the IDE I've selected the board 'Arduino Mini' and the '328' CPU.

Unfortunately, uploading fails with:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

The external reset is connected like in the guide. But I also tried to manually press the reset button (immediately before the upload, or long press and release after upload button is clicked). Still, the same error.

When the manual reset is pressed the pin-12-blinking stops for a while (perhaps the bootloader is then executed) but then starts again.

The Arduino2serial has 3 LEDs. The ON-LED lights up when connected to the USB. When hitting the upload button in the IDE, the RX-LED flashed shortly one time after a while. That's it.

Thus my question: How to I troubleshoot this? Can I test the arduino usb2serial on its own? What's up with the pin-12 blinking of the mini?

In case this matters, I am on Fedora Linux, uploading to other Arduino devices (Uno, Micro) works as expected.

update usb2serial: I just hooked up the Arduino usb2serial and connected the TX/RX pins via a jumper cable - a minicom session then results in text being displayed and the rapid flashing of the RX/TX LEDs. Disconnecting RX/TX again shows no display of any text inside minicom, and no flashing of the RX/TX LEDs.

I used following command line:

$ minicom -D /dev/ttyACM0 -b 115200

Thus, the usb2serial module seems to work.

update: I've checked all the jumper cables and there was a faulty one. With that replaced flashing works. After hitting the reset-button. The 'ext reset' pin is connected but the remote-reset does seem to work. Anyways, hitting the reset-button is easy-enough, for now.

final update: The root cause for remote-reset (a.k.a. auto reset) that the capacity of the used capacitor was too small. After exchanging it with a 100 nF one (as specified in the guide) the remote-reset works as expected. That means just hitting the upload button in the IDE automatically resets the device and the sketch is uploaded.

  • Did you try uploading just after reset? Sep 8, 2015 at 19:04
  • @IgnacioVazquez-Abrams, yes, I did - ultimately, the root cause was a cable (cf. update) - now, the point when I hit the reset-button is relatively non-time-critical. Sep 8, 2015 at 19:44
  • The remote reset is done through the DTR line, iirc, so if that is not wired, reset won't work. You can refer to the schematics for UNOR3, to reproduce the wiring. Sep 8, 2015 at 19:52
  • @Igor, the 'ext reset' pin of the USB2Serial 'mirrors the DTR line of the virtual serial device on the computer' - and was connected to the reset pin of the Mini. Problem was that out of a mistake I used a too small capacitor (< 100 nF). With 100 nF the software-reset works as expected. Sep 9, 2015 at 6:58

1 Answer 1


As always, it makes sense to check the parts in isolation, if possible.

Host system (Linux):

  • Tail the system log for errors
  • Check that ModemManager does not occupies the /dev/ttyACM0 device


  • Connect it via USB to the host without anything else connected -> the ON-LED should be on, the RX/TX LEDs should be off, the system log should display some udev progress messages (including vendor ids), the system should have a new serial device, e.g. /dev/ttyACM0
  • Open the serial port with a terminal (e.g. via minicom -D /dev/ttyACM0 [-b baudrate], disable local echo and type something -> nothing should be displayed
  • Connect the RX/TX pins to each other with a jumper cable -> typing in the terminal session should now result in rapid flashing of the TX/RX LEDs and the echoing of the text

Arduino Mini:

  • Connect just the minimum, e.g. just power from a 9V battery/5V power supply and the reset pin to +5 (with a 10KOhm resistor in series) -> the power-on led should turn on
  • The chance is high that the device comes with a pre-flashed blink examples that either uses pin 12 or 13 -> connect external LEDs to pin 12 and 13 (in series with 220 Ohm resistors) -> one LED blinks after power on
  • Hit the reset button on the mini -> any LED blinking should stop for a while and then continue

Arduino Mini with USB2Serial:

  • Make sure that both RX/TX pairs are crosslinked (like a nullmodem cable), i.e. RX <-> TX and TX <-> RX.
  • Follow the mini guide on arduino.cc or arduino.org it includes a picture of the cabling
  • Verify that the capacitor connected between the USB2Serial 'ext reset' pin and the Mini reset pin has a capacity of 100 nF, otherwise, the auto-reset might not work
  • In case the automatic reset does not work, press the on-board-reset-button just before the upload
  • In case the error persists, check for dodgy cables with a multi-meter


  • Make sure that it works with 'easier' stuff, e.g. flashing to a Uno (the Uno is easier because the USB-2-Serial part is integrated)
  • Enable verbose logging during upload (in the preferences)
  • Update the IDE in case it is very old

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.