My computer cannot detect my Arduino Uno anymore,

  • Reset button- > L led light blinks and it turns on forever
  • Arduino 1.6.5: Tools->Port (greyed out) I remembered that previously it wasn't like this
  • Unable to upload any sketch codes into the Uno anymore
  • The existing code uploaded onto the Uno is FastLED(FirstLight) and it will work on my LEDs when I plugged them in

I have tried to .... but none fix my issue

  • Restart my computer
  • Press the reset button on the Uno
  • Using the device mananger to change COM ports
  • Device manager -> Other devices -> (nothing about Arduino Uno is found here)
  • Plugged Uno into another computer but still doesn't work
  • Reinstalled IDE

Problem shown in sketch,

avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

  • Try to install the ardunio driver again. Connect your arduino to another pc & see if it is working or not.? or maybe try connecting any other serial device to your pc and check if it shows any com ports or not.?
    – Aircraft
    Sep 8, 2015 at 4:40
  • 2
    I'm voting to close this question as off-topic because it has been abandoned for two years without any followup that could make it answerable ever being provided, and it has started to attract low quality responses. Aug 17, 2017 at 21:54

2 Answers 2


I have experienced a similar issue after plugging in another Arduino device. I didn't set up my environment for a long time and thus forgot he iterates the COM-Index. Maybe this is too easy, but you didn't provide much information.

This solved my problem: Open Arduino application > Tools > Port > Change to the target Port

If you are unsure which port to choose from: (on Windows) Open Device Manager > Connections (COM & LPT) > Usb Serial Port (COM[x]) where "[x]" is the index you are looking for.

  • This is dangerously close to an "I'm having this problem too" response. Changing the port seems unlikely to be a solution, since having the port menu greyed out suggests there are no valid choices there to choose. The problem here would appear to be far more fundamental - an electrical fault, bad cable, or bad driver. Aug 17, 2017 at 21:52

Try a different arduino w/ your first computer, see if that will work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.