1

I'm trying to connect to my Arduino board through a macbook pro with mac os x 10.9.3 installed. I'm following the instructions from the arduino guide and in the connection section:

" Connect the Arduino board to your computer using the USB cable. The green power LED (labelled PWR) should go on. If you're using the Arduino Uno or Arduino Mega 2560, a dialog box will appear telling you that a new network interface has been detected. Click "Network Preferences...", and when it opens, simply click "Apply". The Uno or Mega 2560 will show up as "Not Configured", but it's working properly. Quit System Preferences.

I cannot see any ports that hold the USBModem port.

How to setup the connection in the right way?

I read some articles about making a lock folder and I followed them but they didn't work for me, I also tried following this article but the solution there didn't work as well.

2

Sorry about providing this as an answer, rather than comments; however, I do have some suggestions to troubleshoot the connection.

First, check the usb connections with lsusb

    lsusb |grep -i arduino

Similarly, you can try following the output of dmesg; though, I'm not sure about the version of dmesg your system's installation is running. Newer version of dmesg have a "follow" option available. On my Fedora system it's:

    dmesg -wH

Check the output as you plug in the arduino for messages related to the device, such as the resulting location of the tty. As a desperate measure, you can also look in the /dev/ folder for the last modified device, and search your logs for those devices:

    ls -alrth /dev/
  • This is not a applicable answer, as the system in question is not running Linux. – Chris Stratton May 28 '14 at 3:21
0

Under what circumstances does this happen? I see this message whenever I try to download to the Arduino but I've left my terminal program connected to that port. The fix in that situation is to disconnect it (after a <face-palm> to remind myself, yet again.... :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.