0

I've an Arduino Mega 2560 R3 and recently bought a Wifi Shield CC3000 from ebay http://www.ebay.de/itm/201405512301 They write that the firmware has the version ServicePack 1.11.1. The WiFi shield is connected to the Arduino and green status light is on.

I try to run this example code:

void setup() {
  //Initialize serial and wait for port to open:
  Serial.begin(9600);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for Leonardo only
  }
}

// check for the presence of the shield:
if (WiFi.status() == WL_NO_SHIELD) {
  Serial.println("WiFi shield not present");
    // don't continue:
  while(true);
}
...

It seems that Wifi.status() always returns WL_NO_SHIELD. What can I do?

Thanks for help.

  • Are you using a CC3000 library, or the IDE's WiFi library that is written for the Wiznet chip? – Majenko Aug 25 '15 at 19:44
1

The problem is solved now.

  • I imported the Adafruit_CC3000 library which can be downloaded here: https://github.com/adafruit/Adafruit_CC3000_Library
  • I run the example but the output was chinese nonsense
  • Instead of

    Serial.begin(115200);

    I used

    Serial.begin(9600);

    then the examples run without any problem

Thanks @Majenko. His question was very helpful.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.