I was having an issue very similar to this one:

Arduino compatible's serial port not showing Mac OSX

Basically I have a clone (VISduino) and it's made with a different USB chip so it needed a driver. Installing the driver didn't help.



 sudo nvram boot-args="kext-dev-mode=1"

didn't help. So I decided to delete Arduino and reinstall. Then I went through all of the steps again.

Well.... now nothing works. Before doing this I could use:

  • Adafruit metro
  • An uno clone
  • My genuine uno
  • lightBlue Bean
  • adafruit trinket and trinket pro
  • adafruit trinket pro via USB
  • digikey

enter image description here

I've reinstalled the drivers for these but NOTHING is working now. They were all working before. It just says Arduino Uno on COM1, or digikey on COM1 etc.

enter image description here

And of course my clone (vis duino) isn't working either.

How can I fix this?

enter image description here

The com ports just are not there.

  • That's clever - you've got your Mac to give you Windows device names...?! – Majenko Aug 20 '15 at 12:59
  • what do you mean? – futurebird Aug 20 '15 at 13:00
  • COM1 is what windows calls it. I'd expect something like /dev/cu.modem-4d82f3a – Majenko Aug 20 '15 at 13:01
  • well my mac is calling it com1 I posted a photo. – futurebird Aug 20 '15 at 13:07
  • It's saying COM1 because you haven't (yet) selected a serial port to use. This has nothing to do with the Arduino IDE - it's 100% to do with dodgy drivers. – Majenko Aug 20 '15 at 13:14

I solved this issue by deleting all of the Arduino files and the Arduino app. I put my sketched folder aside but deleted all libraries.

Restarted the computer.

Installed Arduino fresh.

Restarted the computer.

Installed the drivers.

Ran the command.

Restarted the computer.

Restarted the computer.

Restarted the computer.

Then it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.