Since I updated to El Capitan Public Beta, my Arduino Uno doesn't show up in the serial devices list.

The System Information utility shows an Arduino connected on the USB port (as 'Communication Device'), but a serial port does not get created at /dev.

The board works on Windows and the previous versions of El Capitan.

The problem persists on beta 6.

  • Which chip does your Arduino use for the USB interface? Is it the CH340 or the PL2303, or some other variant? Did any of the answers help resolve your issue? If so, could you accept the answer the answer that helped you? Feb 12, 2016 at 3:58
  • 1
    @Greenonline Unfortunately none of the answers worked for me. I program my Arduino using an Ubuntu machine, though I'd still try any new answers that might come up. Downloading the PL2303 driver did not work for me. And I cannot figure out what chip my Arduino uses.
    – duci9y
    Feb 12, 2016 at 16:18

4 Answers 4


As noted elsewhere, there have been plenty of problems with the CH340 driver and the OSX El Capitan betas, culminating into the driver flat out not working in the latest beta. This is either a bug with OSX or a bug in the driver. I would lean towards this being a bug in the driver, which hasn't been updated since late 2013.

There are other 3rd party drivers that might work on El Capitan. mac-usb-serial.com is the most reliable looking one that I could find, and it does appear to be actively developed. It does cost money, but it is signed (which the mfg. driver isn't) and it has a test utility you can use before purchasing.

The only other options after that are:

  • Hope that WCH update their driver (don't hold your breath).
  • Program using an external programmer
  • Buy an Arduino not using the CH340
  • 1
    mac-usb-serial.com worked for me in getting a CH34x driver working in 10.11 El Capitan. It was worth the $8 to put an end to fighting with it.
    – k s
    Oct 11, 2015 at 16:41

I have the OS X 10.11 installed and was unable to upload to my Arduino board. I always got stuck with the error code

avrdude stk500_getsync() not in sync resp=0x00

After installing the FTDI driver it didnt't work either. So I figured out Apple provides it's own FTDI driver kernel extension since OS X 10.9, named AppleUSBFTDI.kext. So the AppleUSBFTDI kernel extension interferes with the FTDI driver. An USB port shows up in the Arduino Application, but no communication involving avrdude is possible.

Solution (without modifying or disabling any system security options introduced in 10.11):

  1. Open a terminal
  2. Execute: sudo kextunload /System/Library/Extensions/AppleUSBFTDI.kext/ -> this will unload the Apple FTDI Kernel extension.
  3. Reinstall the FTDI driver
  4. Start the Arduino IDE, select a Com Port, the correct Arduino board
  5. Compile and upload your sketch to the board.

Please note that kextunload will only temporarily unload the module. When your system gets rebooted, you have to do this step again. It's possible to remove the kernel extension, but out of security reasons I don't describe how to do it in this post. If you're familiar with the console, you know how to do this :)

  • I tried the answer that semm0 mentioned, but the terminal said that I did not have the proper permissions to access that.
    – Alex James
    Aug 10, 2016 at 15:34

Check this https://www.youtube.com/watch?v=0zuRukW7o0A

  • Reboot and press CMD+R immediately after reboot to enter in Recovery Mode
  • Open Terminal from Recovery mode
  • Run the command csrutil enable --without kext
  • Reboot
  • Install driver

My version of OS X 10.11 did not have the driver installed for the FTDI cable that I had. I downloaded the drivers here (for free): PL2303 Mac OS X Driver Download

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.