I installed OS X El Capitan beta on my Macbook. Now my Nano-sized Chinese Arduino operating on CH340 chip reboots the laptop when USB is unplugged. While plugged, it works fine, I can upload sketches and send/receive data via Serial.

I've tried reinstalling the CH340 driver and running the following command as per this solution and it didn't help:

sudo nvram boot-args="kext-dev-mode=1 rootless=0"

I appreciate any ideas...

  • If I may ask, how did you get the Arduino to be detected by the computer? Since I updated to El Capitan, I've been unable to get the Arduino detected on the computer.
    – duci9y
    Commented Aug 6, 2015 at 18:27
  • @duci9y Frankly, I did nothing special. I just upgraded from Yosemite to El Capitan, plugged in my Arduino, did a bit of coding as normal, unplugged it and boom, my Mac reboots after about 3 seconds. Commented Aug 7, 2015 at 9:57
  • @duci9y It turns out I didn't have the latest Beta. I now updated to the latest and now my CH340-based Arduino doesn't get detected as well! :) Commented Aug 7, 2015 at 18:59
  • 1
    Ah… so we are at the same place now. I'll post a question about it, maybe someone would know.
    – duci9y
    Commented Aug 7, 2015 at 19:00

5 Answers 5


There is a new signed driver for OS-X El Capitan and Yosemite. This is all you want.



The command you ran only disables driver signing verification, which means OSX stops blocking it. If it is crashing it is likely to be either a bug in OSX, or a bug in the driver. My guess is it is a bug in the driver and you'll probably have to wait until they release an updated version that is compatible with El Capitan.


It turns out I didn't have the latest Beta. I now updated to the latest and now my CH340-based Arduino doesn't get detected at all! Pretty much in line with everyone else complaining all over internet.


Check this video https://www.youtube.com/watch?v=0zuRukW7o0A

  • Reboot and press CMD+R immediately after reboot to enter in Recovery Mode
  • Open Terminal from Recovery mode
  • Run the command csrutil enable --without kext
  • Reboot
  • Install driver
  • helped me, thanks. First I ran csrutil disable and it worked, however I feel better with your suggestion because it doesn't disable Protection System
    – boweidmann
    Commented Oct 16, 2015 at 16:25

If you have macOS High Sierra like mine 10.13.4 This is work for me https://github.com/awangga/NFCReader

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.