0

I'm using a 5v Pro Trinket that has an Adafruit Ultimate GPS connected and is connected over serial to my laptop. I am not using any fancy parsing code, I'm just letting the GPS spit out the raw data. When I connect to it over the Arduino Serial Monitor, I get all the GPS info and it's highly accurate. I have also tried the Mini GPS v1.4 program and that seems to work really well too.

However, for some reason when I try to get a live feed in Google Earth (and I also have the check box that allows Google Earth to automatically follow the path), it doesn't actually do anything. After starting the feed over serial, I get this message for four seconds: "Reading COM3" and then for a split second I get: "Reading COMPOSITEBUS#MS_IMPLAT_MP#{B17FDEA3-E8A2-45B0-8CAC-85938CA04809}#{ad498944-76f-11d..." The string goes for several more numbers and such (I'm not sure if that's important, I will post the whole string if needed).

Does anyone know what's going on here? Have I missed a step to make the raw data more compatible?

Thanks in advance! -M2com

  • What output mode do you have the GPS in? NMEA? – Jake C Jul 24 '15 at 2:20
  • Also how are you connecting the trinket to both the computer and the GPS? Last I knew the ATMega328P only has one UART. – Jake C Jul 24 '15 at 2:21
  • The GPS output is NMEA. The Trinket is connected via FTDI to the laptop (Windows) and the GPS is the Adafruit Ultimate GPS unit that is connected via GPIO to the Trinket. Hope that helps. – M2com Jul 24 '15 at 3:59
  • Have you tried just using the adafruit Echo example? – Jake C Jul 24 '15 at 5:48
  • Yeah that unfortunately didn't work either. – M2com Jul 24 '15 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.