1

I have a max7219 driving an 8 digit 7 segment LED array with forward current of 20mA and typical forward voltage of 1.85V. I'm trying to power this through my arduino UNO (which itself is drawing power from USB), and have the max7219 chip's +5V and ISet(+resistor) and ground pins connected to the respective pins on the arduino. When I try to plug this in, the arduino will not power up, but removing the jumpers from +5V and GND allows the arduino to power up.

I have confirmed with my multimeter that there is no short between any of the power cables on my led circuit.

The voltage supplied by the arduino works normally if I connect it up to a simple resistor and led on a breadboard.

The voltage across the +5V & GND pins on the arduino drops from 5V to 0V if the jumpers are inserted whilst the arduino is powered up.

I thought perhaps the circuit was trying to draw too much power from the USB, so tried higher resistor values than my initial resistor (20K), to no effect.

What else could be causing this?

  • Are you running the Arduino direct from the computer's USB port or from a USB hub? If the latter, is it a powered or an unpowered hub? – Majenko Jul 14 '15 at 15:14
  • Your circuit is using to much power. This will trip the resettable fuse on the Arduino. That's why 5v will go to 0v. Since the max7219 shouldn't draw the 500mA needed to trip the fuse, you probably miswired something. Could you add a picture of your wiring? – Gerben Jul 14 '15 at 15:23
  • @Gerben It may not be. It may be the USB host port being shut down through too much current draw. An unpowered hub will (should) shut down at more than just 100mA. – Majenko Jul 14 '15 at 15:34
  • @Majenko Different result, but still the same cause. PS I've seen unpowered hub with no fuses at all. And motherboards with 900mA fuses (2 ports per fuse I think; maybe). – Gerben Jul 14 '15 at 15:52
  • It's a usb3 port directly from the mobo. The general consensus is too much current draw, which is what i suspected. Now to work out why...I don't think a picture will help much - the circuits on two sided protoboard and a lot of wires are hidden under the displays. I must have miswired something, perhaps transposed the max +5v and Iset wires. That could explain it. Thanks for the comments. – Ty Hayes Jul 14 '15 at 16:14
1

and have the ... ISet(+resistor) and ground pins connected to the respective pins on the arduino.

What pin on the Arduino?

The ISet resistor should go to +5 V - don't connect it to an Arduino pin (unless you mean the +5 V Arduino pin). See diagram:

MAX7219 wiring for 7-segment display

I had a 7-segment display working fine on an Arduino via the USB, see photo:

7-segment display with Arduino

More details here: Interfacing LED displays with the MAX7219 driver

  • Sorry for the confusion. I did indeed mean that ISet was connected to the +5V pin on the arduino. I managed to get it going fine on a breadboard, I guess I must have shorted something when wiring/soldering my final board. However, my circuit doesn't include the capacitors in the top left of your schematic (and indeed I don't see them in your photo). What purpose do they serve? – Ty Hayes Jul 15 '15 at 15:57
  • You are right, I didn't have them. However they are in the schematic as the standard recommended decoupling capacitors - read the link for more information. The larger one provides an "energy well" to cope with fluctuations in the supply voltage over the connecting wires, the smaller one smooths out sudden spikes in Vcc which might cause the digital logic to misbehave. – Nick Gammon Jul 15 '15 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.