1

I have an Arduino UNO and a 16x2 LCD Shield that have been lying unused for one year, or perhaps more. Yesterday I connected the Arduino via USB, uploaded a couple of simple sketches, played around with the LED and button bricks and everything seemed to be working fine. Then I tried to connect the LCD, but it wouldn't work. I eventually adjusted the potentiometer until one row had solid white squares on it and the other did not, with the backlight lit.

I tried both connecting the shield directly on top, or separately using wires and wiring up the +5V, GND and 12, 11, 5, 4, 3, 2 pins. I also checked the wires and the pins using digitalWrite and digitalRead. The problem doesn't seem to be there. No matter what I try I cannot get it to display anything else other than squares.

I have tried using different pins and changed the LiquidCrystal initialization accordingly, I have also tried the I2C Scanner and it just kept reporting that no LCD was found (with the shield mounted and lit).

I have no idea what to do next or how to determine whether the LCD panel controller is broken or not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.