3

Not sure if this is the right place to post this.

I have an Arduino Due I'd like to start using. I've been using Unos, Megas etc no problem. The newer IDEs have removed the Due support. I've been trying to install Due support through the Board Manager, but it just says there is an error downloading the files.

Is there a way to manually install the board support for the DUe, or must it be done automatically, connecting through the internet?


UPDATE

When I open the Boards Manager, I get :

Error downloading http://downloads.arduino.cc/packages/package_index.json

and when I try to install Due support, I get :

Error downloading http://downloads.arduino.cc/cores/sam-1.6.4.tar.bz2

I understand I may be behind proxies, but in IDE version 1.6.5, that has been removed from the Preferences, so I can't change that. I have tried to allow the IDE past the Windows Firefall, but that has not changed anything.

I have manually downloaded sam-1.6.4.tar.bz2 and extracted the contents to C:\Arduino\arduino-1.6.5\hardware\arduino\sam (I had to manually create the sam folder). With this, I can see the options of Arduino Due Native USB Port and Arduino Due Programming Port when selecting the board, and when I look for it in the Ports, it can recognise the board at the port (eg "COM5 (Arduino Due (Programming Port))" ). When I try to compile anything, I get the error message :

Cannot run program "{runtime.tools.arm-none-eabi-gcc.path}\bin\arm-none-eabi-g++" (in directory "."): CreateProcess error=2, The system cannot find the file specified

Any other idea as to how I can install the Due? Is there an option for a manual installation? The same happens with Libraries Manager (I don't get a connection), so I guess, the same can be applied to that.


UPDATE 2

Question has been answered: https://github.com/arduino/Arduino/issues/3358

Many thanks to Federico Fissore!

  • I just installed the Due fine using the board manager. What is the problem you are having? – Majenko Jun 17 '15 at 15:23
  • If there is an error, you should report it to Arduino github github.com/arduino/Arduino/issues – Federico Fissore Jun 18 '15 at 6:37
  • @Majenko When I open the Boards Manager, I get : "Error downloading downloads.arduino.cc/packages/package_index.json" , and when I try to install Due support, I get : "Error downloading downloads.arduino.cc/cores/sam-1.6.4.tar.bz2" . I understand I may be behind proxies, but in IDE version 1.6.5, that has been removed from the Preferences, so I can change that. – Tom Jun 18 '15 at 7:48
  • @FedericoFissore I will try there as well, but if you have an answer, can't you just it here? – Tom Jun 18 '15 at 7:50
  • @Tom I don't have an answer, but if you are TheForeignMan on github, then we are already chatting :) – Federico Fissore Jun 18 '15 at 11:41
0

I had the same problem described above. Error downloading http://downloads.arduino.cc/packages/package_index.json

I solved the problem, just deleting the temporary file: "package_index.json.tmp"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.