I have an Arduino Uno attached to my MacBook Air running the Arduino IDE 1.6.4.

The Arduino was visible in the Serial port section this morning, but then it just disappeared. The ON light on the Arduino still comes on, but I cannot connect to it through the port section. I attached the Uno to another computer and it did not appear there either. However, when a different Arduino is connected to my computer it does show up. I also tried using a different IDE version, and it did not appear there either.

All of the other topics I found regarding this were saying it is the OS's fault, but since I was able to see the other Arduino, I am pretty sure it is not. I updated the FTDI drivers, and I tried using a powered hub and it is still not there.


When I took the chip out of the UNO that is not appearing and put it into a working UNO, I was able to see it, is it possible that the Serial port is just not working, and if so how would I fix that

Any help would be appreciated.

  • Have you consider that your arduino is may be burned.
    – Akkilah
    Jun 13, 2015 at 17:08
  • 1
    Is anything plugged in to the arduino? does its power light come on? Can you tell if its running the last program you uploaded still? Jun 13, 2015 at 17:32
  • This doesn't seem to be the case since it works on another computer... Jun 13, 2015 at 21:41
  • Step one: from a terminal, run sudo dmesg and note the last line. Step two, plug in the Arduino. Step three: run sudo dmesg again and find the same last line. Step four: post what comes after that line into your question.
    – Majenko
    Jun 13, 2015 at 21:48
  • 1
    @BrettAM There were things pluged into the arduino but I took them off and the arduino still did not show up, the power light is on, and I am not sure is the last program running because all it did was print to the serial monitor. Jun 14, 2015 at 9:11

2 Answers 2


If the Arduino doesn't show up on multiple computers, and others do, it may be bricked, or dead. You might try reflashing the chip, and hope that solves your issue. If it doesn't, chances are it's toast.

If however the device simply doesn't show up on one computer, but does on another. It's either a software issue, or a USB issue with that computer.

If winblows OS, try reinstalling, or updating the drivers for the USB, as well as the Arduino. And check your power management on the USB as well. I've seen Windows USB poop the bed if a device is connected / disconnected, or restarted several times in rapid succession. When this happens, sometimes Windows will think the port or device is faulty, and simply stop responding to its presence.

If *nix, make sure you've configured it properly.


When an Arduino stops appearing, it is usually because it's fried. Especially if other machines appear when connected, and the faulty machine appears on no other machine.

Try burning the bootloader.

  • I do not the bootloader is broken as when I took the chip out of the board and put in into another board that board was able to be seen Dec 13, 2015 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.