I am trying out some code using the Arduino IDE. The code basically tries to connect to a server and push some data to it.

When I upload the sketch to the Arduino from Mac (Apple PC running on Mac OS) the code works as expected without an error.

However, when I upload the same code/sketch from a Linux machine on Ubuntu, the arduino does not operate as expected.

I tried taking a diff comparison of the HEX files created in both machines to check whether there are any differences (expecting very few). But found that there a lot of differences.

What am I missing? Why isn't my code working when uploaded via the Linux PC!!!!!

  • Make sure you're using the correct versions of libraries / IDE you use. Compiler version could be different, but should not matter in most cases. Also you need to give more details, otherwise guesswork is all we can do. – fuenfundachtzig Jun 12 '15 at 20:19
  • Just got it sorted. Like you said the problem was with the Libraries used. Different version were used in both PCs – Shabirmean Jun 12 '15 at 20:28
  • 'MAC' == Media Access Control, the unique ID given to each Ethernet or WiFi interface. 'Mac' is (sometimes) used as a nickname for Apple, Inc.s desktop and laptop computers. I've edited the question. – JRobert Dec 11 '15 at 0:05

Got this sorted.

The issue was that different versions of the library was being used in both the PCs. One we made sure that the Linux PC used the same as the MAC one it all worked fine!!!

Thanks Guys

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.