1

I am a newbie in arduino. I successfully installed driver for arduino atmega 8l, which were provided by the company i bought arduino from. The driver is PL2303 by prolific. The reason i m mentioning this is because at first i had some problems in installing them. Now after i have made a blink program. I thought of uploading it. Whenever I try to upload i get this error: avrdude: arduino_read_sig_bytes(): (a) protocol error, expect=0x14, resp=0x75 avrdude: error reading signature data for part "ATMEGA8", rc=-2 avrdude: error reading signature data, rc=-1

My computer: Windows 7 32-bit I tried pressing the reset button before uploading, i get the same message. I tried it in another computer of mine. There the driver is showing a code 37 error so basically my other computer is not reading the arduino.(also my board comes with bootloader already innstalled). Thank You

  • You have to select the correct board from the Tools->Boards menu. – Gerben Jun 8 '15 at 12:56
  • @Gerben i have selected the correct board as well as the serial port. I have select arduino ng or older with atmega 8 and serial port com25 in my case, the board info was given by the manufacturer of arduino – AadityaCool Jun 9 '15 at 6:08
  • I thing 0x75 is for a ATMega16, not an 8. Please look at the main chip on your board. The type should be written on it. – Gerben Jun 9 '15 at 17:46
  • @Gerben I already have checked the chip. Its is an atmega 8, I know how to program in 8 languages but electronics was new and i do want to try it, so i just ordered a new board, but would like to see this running too though and thanks for helping me out – AadityaCool Jun 10 '15 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.